Jump to content
  • Welcome To Mopar1973Man.Com

    We can see you are lurking about reading the forums and article databases. We happen to be one of the most friendliest Cummins support website on the planet. Come on and register and grab a inexpensive subscription plan. With that you can unlock even more for you. Technical support either by public forum, private support ticket, and even unlock phone support by Mopar1973Man. Mopar1973Man.Com will remain FREE to read forever!

4th Generation Ram 6.7L Reliability / Performance

This is a discussion forum of the 2010 to 2018 4th Generation Ram Trucks with 6.7L Cummins Turbo Diesel of performance and longevity. This includes tricks of getting more MPG, HP/TQ, or just getting to the next milestone.


64 topics in this forum

    • 0 replies
    • 361 views
    • 0 replies
    • 229 views
    • 1 reply
    • 262 views
    • 28 replies
    • 697 views
    • 5 replies
    • 477 views
    • 0 replies
    • 95 views
    • 4 replies
    • 1.2k views
    • 19 replies
    • 1.7k views
    • 5 replies
    • 362 views
    • 6 replies
    • 427 views
    • 5 replies
    • 902 views
    • 0 replies
    • 889 views
    • 2 replies
    • 717 views
    • 0 replies
    • 683 views
  1. I made the jump

    • 7 replies
    • 2.1k views
    • 5 replies
    • 2k views
    • 5 replies
    • 880 views
    • 13 replies
    • 1.2k views
    • 3 replies
    • 1.8k views
    • 0 replies
    • 791 views
  2. Garage - Ram 2500

    • 0 replies
    • 911 views
  3. Garage - nameless - 3500

    • 1 reply
    • 1.5k views
    • 1 reply
    • 1.6k views
  4. Bully Dog GT+

    • 2 replies
    • 1.1k views
    • 7 replies
    • 3.4k views


  • Forum Statistics

    • Total Topics
      17,283
    • Total Posts
      233,650
  • Popular Now

  • Latest Products

  • Posts

    • I looked at dap, now they're like $550 to rent then they refund the $500. They really should explain that better though. It's unclear in the description.  I'll have to call around, we have a few dodge dealers in the area I can try.  It would be nice to have this feature enabled for those cold nights when I get done at work. Sometimes truck will sit there til 4-6am I work a 12 hours shift roughly. So it sits out without the block heater plugged in that whole time. Seems to take awhile to warm up.
    • Okay, never remembered that. How do you get non metallic grease?
    • Remember if you get too much metallics in the grease between the tone wheel teeth the the ABS will freak out and set the ABS and BRAKE lights. Not something I willing to suggest. The tone wheel should be kept clean and not filled with grease. Being if the grease has a bunch of metallics then the ABS doesn't count the frequency even and may or will cause ABS issues later on.
    • Dieselfuture is the one who first brought it to my attention of greasing the front hub bearings thru the ABS sensor hole. Now on my third front hub replacement yesterday in a couple years to both my 2nd gens you tend to get tired of the expense and time. I was only in there to replace the brake pads and discovered a rough spot in the wheel hub bearing. The only way to tell was to turn by hand with the wheel, the caliper and rotor off because just a few weeks earlier I had checked for looseness in the wheels, so on I went with a new Timken hub. This time they got me for over 300 bucks because I needed one right away to be up and running by Monday.   Now before removing the old hub with the rough spot, I removed the ABS sensor and pumped a bit of grease down the hole while turning. Wow that really did improve how smoothly it turned. Thanks Diesel future . I went on to replace it anyhow and found leaking caliper pistons.... on an on!    Oh yeah, no I didn't use chicken grease Dripley, I know how you are about animal rights, but I am greasing all four hubs on my trucks from now on.
    • My last Quadzilla failure was similar. I found that my ring terminal for ground was lose and created the same problem you had. I've seen one other vehicle with a bad set of red and red/white wires so the Quadzilla wasn't getting good power. Disconnecting the CANbus just stops the Quad from talking to the ECM and VP44. If it straightens out then look into the wiring more so and double check all the connections.    DO NOT hook directly to the battery for either the RED positive or the BLACK ground wires. In the PDC box there is a red wire stud in there to get power. Then hook the black to a the body or engine block it doesn't need to be on the battery at all. 
×
×
  • Create New...