Jump to content
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel forum. We are very friendly and helpful group of Dodge Ram Cummins owners. We will try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use. 

     

    Registration is free. Registering on the site will provide access to many more things like...
     

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members. Post up your used parts and vehicles.
    • Member Garage where you can proudly display your vehicles and modifications that you have done to them.
    • Download files, documents, and Quadzilla Adrenaline tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.
    • Reduced Advertisements displayed to you.

Recommended Posts

Heres the new dilema with the wifes truck.:mad: The darn transmission wont come out of first gear. I got first, reverse,park and neutral. Is there a electronic part in this thing that could make it not shift into second and third. She doesnt haul anything, Im trying to figure this one out. Would changing the fluid and filter help?? Any suggestions on the shifting problem would again be helpful!!!:thumbup2:

Share this post


Link to post
Share on other sites

Check for codes first off. How high have you taken the rpm to see if it shifts? If the governor solenoid is sticky it will cause it to have a delayed upshift. could also be the speed sensor gone bad. First we need to know if there are codes.

Share this post


Link to post
Share on other sites

No codes...The transmission shop said it just might be a broken 2 gear band and they could fix it for $200. Hopefully thats all thats wrong with it.

Share this post


Link to post
Share on other sites

No codes...The transmission shop said it just might be a broken 2 gear band and they could fix it for $200. Hopefully thats all thats wrong with it.

Did you find a fix?

Share this post


Link to post
Share on other sites

You are saying the band strut is bad so it won't shift out of 1st. gear. Mine will shift if you let off the throttle.

Share this post


Link to post
Share on other sites

be careful theres a differance between broken and stretched, broke no shift, stretched failure to shift under load, and i have seen the lock nut on the band adjustment work loose and back the band off, the nut will be just siting in the bottom of the trans pan when removed

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×