Jump to content

Sluggish acceleration


Recommended Posts

When pushing down on accelerator pedal,sluggish response almost dead pedal,truck sounds rough. If you cycle key switch on/off, truck clears up and runs fine.it only does this intermittently, but cycling the ignition switch always resolves the issue. Any ideas,bad relay or switch contacts?

Link to comment
Share on other sites

I have not used a scanner yet. I will see if I can acess one. The only code on the Odometer readout is P1693. Fuel pressure is 7psi. Only a small amount of black smoke. If I toggle the key switch real fast on/off it clears up and runs great. This fixes it every time?

Link to comment
Share on other sites

  • Administrator

go to a parts store and scan for codes.  the truck is trying to tell you whats up 1693 means there is another code.  

 

http://articles.mopar1973man.com/2nd-generation-24v-dodge-cummins/26-engine-systems/89-obdii-on-board-diagnostics-diagnostic-error-codes

 

I am guessing you have a bad crank sensor or something like that.

Link to comment
Share on other sites

Like ME says you need to stop at an advance or autozone or such  and have them check for codes. That will get you pointed in the right direction. Kind of a guessing game without them. It can be guessing game with them sometimes, but they help.

Link to comment
Share on other sites

7psi fuel pressure is low, is this @idle or WOT???

IF THIS IS AT IDLE YOUR PROBABLY DOWN TO 3-5PSI @WOT... with STOCK CARTIER PUMP....... May not be your issue now but it will almost certain to be 1 in the future 

Edited by rburks
Link to comment
Share on other sites

  • Administrator

When pushing down on accelerator pedal,sluggish response almost dead pedal,truck sounds rough. If you cycle key switch on/off, truck clears up and runs fine.it only does this intermittently, but cycling the ignition switch always resolves the issue. Any ideas,bad relay or switch contacts?

 

This means there could be internal ECM issues. If you cycle the key your rebooting the ECM. Just like cycling the power switch on your laptop. The computer must go back through and reboot. This is why I always say do not disconnect the batteries because it will not reset computers. Thee software is flashed to the PROM and will not change with disconnecting the batteries. But cycling the key dumps the active RAM and causes in flight reboot.

 

Now do you see any delay in the WAIT TO START light? Randomly or other wise?

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Sorry guys, i have been out of town for a while. I did get scanner codes from the ECU. P0216,P0230,P0380,P0252,P0251. My assumption is that my ingection pump is shot. Do you recommend a reliable source for these? Thanks very much for everyones input, it is very helpful.

Link to comment
Share on other sites

×
×
  • Create New...