Jump to content

Recommended Posts

Up date on vp from h--- it took about one month for pump to go from dieing once in a while to dieing over 100 times in 10 mile could not take it any longer pull it in grage and ordered new pump. We will see how good BD is on there warranty, 5 months old. Oh and never threw a code. I will try to keep you up dated on what happen to it if BD will let me know.

Share this post


Link to post
Share on other sites

Wish you luck with it, that fuel system is the Achilles heal of these engines. Blue Chip warranted mine after 8 months, but it would have been voided if.1 If the wire on top was nicked or tapped2 if the diaphragm was ruptured 3 Rust or water in the fuel.Sounds like you most likely have a dead computer on top.

Share this post


Link to post
Share on other sites

This will be the fourth pump, 17k miles to the pump. That will make you cry uncle.

Sounds like you should go with the P-Pump?

Share this post


Link to post
Share on other sites

Something is wrong... I would check ground wires... There is a master ground hidden behind the starter. You don't blow up 4 injection pumps in 17K miles... There is something causing it...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×