Jump to content
  • Welcome To Mopar1973Man.Com

    We can see you lurking about Mopar1973Man.Com reading articles and reading other member's posts. Are you trying to solve a problem with your Dodge / Ram Turbo Diesel Cummins? We have lots of helpful members and staff on the Mopar1973Man.Com and are willing to give guidance on how to fix or improve your truck. Sorry, we are a subscription website now. We are not corporate owned like many of the other websites out there. Like Cummins Forum (VerticalScope Inc.). Mopar1973Man.Com is entirely privately owned and operated since 2004. Your subscription funds goes towards server maintenance and software maintenance. We happen to be one of the most friendliest and helpful websites  for Cummins Owners in the world. Come join us and register and then pick a subscription plan.

Steering gearbox input collar won't seat


Recommended Posts

Hello all,

 

I purchased a reman gearbox today and was very close to completion when I ran into a problem. The input collar that comes down from the telescoping end will not slide over the splines on the gearbox. I line the flat edge up with the corresponding side, wiggle down, and it only goes down about an 1/8 inch or so and sticks. I tried expanding the collar with a screwdriver thinking it was too tight from the previous box, but that doesn't seem to work either. I've cleaned up the splines really well and sprayed a bit of WD-40 as well with no luck. I have since stepped away for the night as the frustration began to build. Am I forgetting something simple here? when I slid the collar back off the original, it went right back with no issues, so I don't see why it would be so tight. All help is greatly appreciated!!

 

Austin

Link to post
Share on other sites
  • Administrator

Is the bolt out of the hole?

 

As long as the bolt is out of the hole you should be able to tap the collar over the splines and lightly tap it into place. At that point you can insert the bolt. The bolt acts like a lock to prevent it from sliding up and off the splines.

Link to post
Share on other sites

That's how I have felt about the situation! Ha. I've noticed a burr on the flat section of the collar that may be enough to catch. I'll file that down and see if I can get it on from there. If not I suppose my next move is taking it back out and perhaps returning it for another? The splines seem ok on the box side but that's just a quick inspection. My other thought is replacing the collar. Is that difficult and/or not recommended?

Link to post
Share on other sites

yes I believe I have the right box, I didn't get an aftermarket box or anything... Everything else fit perfectly, is that alteration the only one you have to make for that box? I also filed down any imperfections I found and still no-go. I can't purchase just a collar, I'd have to get the whole column for around $150. Not sure it's worth it to go that route. 

Link to post
Share on other sites

Meant more do you have an oem shaft.

 

Mine was hard to get in .... had to pull and wiggle with small leverage ......

 

If you get real stuck might have to pull gearbox and shaft and get seated on ground to make sure all fits 

 

Then reinstall. 

 

 

Link to post
Share on other sites

Well I managed to get the collar on while still in the truck. I had to file down the splines slightly and then give it some love with the hammer, but it finally seated.

 

this may be a dumb question but following the install it is easier to turn to the left then turning right. Is there an adjustment that would fix this?

Link to post
Share on other sites
  • Administrator
6 minutes ago, Austin said:

this may be a dumb question but following the install it is easier to turn to the left then turning right. Is there an adjustment that would fix this?

 

Sound like a power valve problem internally. (Educated guess)

Link to post
Share on other sites
  • 2 weeks later...

Update: went ahead and returned that box as defective and put another one in and it seems to be doing much better so far. Also, the collar slid right on with no problems so maybe I should have taken that as a sign and returned it then and there. Thanks for everyone's help.

Link to post
Share on other sites


  • Forum Statistics

    • Total Topics
      17,199
    • Total Posts
      235,070
  • Member Statistics

    • Total Members
      8,335
    • Most Online
      1,277

    Newest Member
    devinm86
    Joined
×
×
  • Create New...