Jump to content

Archived

This topic is now archived and is closed to further replies.

xxTJRocksxx

6.7 ISB Surging issue with H&S Mini Max

Recommended Posts

Hi Guys, So Posting this on behalf of my good buddy, he spent wayyyyyyyy tooo much money figuring this problem out for me not to summarize and post something.

 

-4th Gen 2010 Ram 2500 Bighorn

 

Background - So While the truck was still under factory warranty, there was almost no issues or gremlins with the powertrain. After the warranty ran out, my buddy ordered an EGR, and DPF delete kit. Then he followed up with the Mini Max, and that's where the problem started.

 

The issue - After the mini maxx, the truck ran all around great, but after a few months there was an intermittent stutter coming to a stop.

 

What did not fix the truck - Replaced CP3, Injectors, headgasket (ARP Studs), Fan Clutch, Cummins ECU, Ram PCM, and an array of MaP, Crank, and cam sensors.

 

The Final fix - It appears the factory ram fuel system cannot handle any aftermarket demand, so a FASS titanium system was the final resolution for this wallet draining frustration.

Share this post


Link to post
Share on other sites

That's a LOT of money to find out the cause was lack of fuel....

 

I would think he could see the rail pressure on the screen and tell that it was lacking. Hard lesson learned! Don't throw parts; Always diagnose. 

Share this post


Link to post
Share on other sites

Why a live data tool so you can watch rail pressure and fuel pressure gauge so you can watch the supply to the CP3 is good idea. 

 

I had one come in that had a bad lift pump still won't run after warming up. Come to find out the #4 connector tube was loose and as the heat expands the head the leak was in the head and was losing rail pressure. Again the live data tool spotted this.

Share this post


Link to post
Share on other sites
On ‎11‎/‎12‎/‎2016 at 9:27 AM, Mopar1973Man said:

Why a live data tool so you can watch rail pressure and fuel pressure gauge so you can watch the supply to the CP3 is good idea. 

 

I had one come in that had a bad lift pump still won't run after warming up. Come to find out the #4 connector tube was loose and as the heat expands the head the leak was in the head and was losing rail pressure. Again the live data tool spotted this.

Yeah I agree, but he took the truck to his trusted mechanic day one, as well as every stealership in FL. It finally took the guy a couple weeks driving around town with the data logger to identify the fuel pressure issue. We had even discussed lift pressure at the beginning, reflecting upon my VP44 lift pump failure / P0216 / VP44 Change which was caused by a clogged pickup tube, however the guy kept "Finding bad parts" and giving his truck back "Fixed", just to be broken a month later.

Share this post


Link to post
Share on other sites



×