Killer223

electrical gremilns.

5 posts in this topic

So, on my 08, Wife was pulling it into the driveway last night, the FRONT passenger side parking light was on while she was pressing the brake. release the brake, light goes out.
i have her double check,
all the lights work when the light switch, everything seems to be ok. but this cross feed or something..

again. press brake, front right passenger parking light will illuminate.

Share this post


Link to post
Share on other sites

Might be bad ground on brake light. I have seen this on older vehicles 

Share this post


Link to post
Share on other sites

i was thinking more the lines of a bad break light switch to let the juice back feed to the front. maybe even the light switch, i'll remove the rear taillight and see what i come up with.

Share this post


Link to post
Share on other sites

New to site need help 08 cummins pulsating lights all of them it starts when I use my rear window or high to low beam or power windows or anytime I apply a load to the electronics but if I turn the blower motor to high it will quit in about 10 seconds please help I am pulling my hair out over this one

Share this post


Link to post
Share on other sites

I have seen this before on an old 88 Chevy.  We had some corrosion making contacts in the trailer lights plug on the bumper.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now