Jump to content
SmokinACE

New APPS, reset now P0222 error?

Recommended Posts

Hello guys, I've been working on a 2000 5 speed truck for a friend that's got me scratching my head. Truck has just over 300k on it and was cutting out randomly and would shudder and he said it was worse when it was cold. Truck had no error codes, new fuel filter, both batteries and alternator are new. I drove it my Snap on scanner on it watching live data on a graph. I could see the APPS signal going whack when truck would act up. Had another VP truck at the house so "borrowed" good working TPS quick to verify that was the issue. Truck ran great with that factory style TPS with no issues. So I ordered the "commercial grade" APPS sensor from DieselAutoPower.com since they are close to me and shipping would be quick.

 

I installed updated TPS, followed instructions on idle Voltage adjustment and adjusted torx bit in some to take the slack out until the voltage went up then backed it off a half turn or so like instructions say. My voltage reading is around .640 volts at idle when the old TPS was around .480ish. New APPS won't adjust any lower. I performed the throttle calibration procedure as per DAP's instructions turning key on, run pedal down slow and back up, key off. I did this three times like it said and truck ran great. I put a fuel pressure gauge on pump to double check lift pump pressure and it was 0-3 psi so I ordered and installed new Airdog/Raptor factory replacement pump at same time of APPS install.

 

I put some miles on the truck to make sure it was all good and it seemed to be. Friend came and got the truck and later said the RPMs were hanging and sometimes wouldn't come down from 2000 rpm or 12-1300 rpm. My first thought was the throttle cable was sticking as it was starting to fray om the engine side. Went to verify and adjusted the idle stop back just a bit more then recalibrated APPS again this time with the unhooking the batteries for 15ish minutes and running pedal up and down slowly with park brake on. We drove the truck and it was all good, then he called me again saying it still hung sometimes but if he bumped throttle it would come down.

 

I ordered new throttle cable and drove it before I replaced it to see if it did it to me but it did not. So I replaced the cable anyway and still could never get RPMs to hang. But...now I had the P0222 Idle validation signals both low code come up while test driving. Cleared the code and it did come back, seems to come on when truck is idling. I followed the P0222 code diagnostics on here and harness between ECM and APPs check out OK and troubleshooting tree points to ECM. I swapped ECMs with a friends 99 and error didnt follow ecm. I did not have ECMs swapped very long though as his had a crank sensor so both trucks had less power and crank/cam sensor codes with ecms swapped. Swapped ecms back and calibrated throttle again. Code still comes back but truck seems to run fine so far. I also checked for AC voltage at batteries and it was below the spec in the test, like .019 or something if I remember right. I've tried Recalibrating TPS every which way and even left the batteries unhooked overnight and code still comes back. Does this sound like a familiar issue to anyone? I'm just not 100% sold yet that its and ECM? Because why did it never throw this code or any code before new TPS? Should I try another APPS first? Is the factory style a better option in this case? Is the idle voltage too high causing it to not like what it sees? Sorry for the long post but thank you for any input! 

Share this post


Link to post
Share on other sites

Timbo's APPS has no electronics. It completely mechanical. Where the OEM and Wells APPS have electronics to handle the logics of the IVS (Idle Validation Switches). 

 

Timbos APPS

Image result for mopar1973man apps

 

Wells APPS

Image result for mopar1973man apps

 

OEM APPS...

Image result for mopar1973man apps

 

 

10 hours ago, SmokinACE said:

My voltage reading is around .640 volts at idle when the old TPS was around .480ish. New APPS won't adjust any lower.

 

Voltage doesn't matter to the ECM. Voltage matters to the APPS. So like OEM the voltage on the tag is typically 0.5xx Volts. When the voltage rises above the tag voltage the APPS flip-flops the grounds signal to the ECM tell the ECM to pay attention to the voltage for throttle information. When it drop below the IVS flip-flops again and ground is signal for idle mode and the ECM IGNORES the APPS voltage and uses strictly on board idle software. So with your case basically both IVS signal lines are shorted to ground and the ECM doesn't know if your throttling or idling. 

 

So now back to Timbo's APPS the whole voltage thing is obsolete because its no longer used. The IVS is based on bellcrank ANGLE not voltage. So APPS voltage has no bearing on if the ECM see idle or not.

 

Image result for mopar1973man apps

Edited by Mopar1973Man
  • Like 1

Share this post


Link to post
Share on other sites

I believe this "commercial grade" APPS from Diesel Auto Power is the Wells style? Is it possible it is bad even though my voltage checks seem ok when testing with a meter? The original TPS would read fine with a meter as well but i could see the reading going nuts on my scanner. Scanner reading with new TPS is smooth and normal. Do I need to go with a Timbo style to make this work right or do I still have a possible ECM problem?

Share this post


Link to post
Share on other sites

Tough call. Somehow you need a known good APPS sensor and then you'll know if the problem is ECM or APPS

Share this post


Link to post
Share on other sites

I while back I had some surging issues with Apps codes. One thing I did was buy a cheap apps off of Ebay, $16 worth of cheap. It did stop the surging and the codes I was getting disappeared. I did however end up with a 222 code that would not go away. It worked fine and the surging was gone. Put a new Timbo on and the surging came back. As the president of the electronically challenged members here, I have no idea as to how any of this works, just thought I would throw this in. I also in no way feel the Timbo had anything to do with it. It is a good product and the one my truck has been in for over 200k. pretty sure my issue is in the wiring.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×