Jump to content

Sucking air at hard pulls


Recommended Posts

I got a 2001 24v with 150hp injectors air dog150 with sump kit  at wot 15 lbs quadzilla programmer and a year old hot rod pump the problem I’m having is when I get on my truck and let off slowly is dies and I gotta crack the lines to get it to fire up and body know why it’s doing this thanks 

Link to comment
Share on other sites

It's probably not sucking air it could be the issue some have with too much pressure in cylinders on high boost situation and letting off to fast causes pressure to be injected back through the injectors. What's weird is you say it does it when you let off slowly it's usually the opposite. I may be way off here too, just a thought. 

Link to comment
Share on other sites

  • Board Of Directors

Raptor does insert a fine mesh screen inside the inlet side of their pumps. It will clog if not a filter on the suction side or just pull it out using the tip of a screw, but you need a prefilter for sure.

Just don't know about AirDog set up.

 

No doubt air is getting in from somewhere. Something in the system is letting it in from the suction side perhaps, but I would check everything. Even all filters. Make sure factory filter cap is tite to 25 ft lbs with the gasket set in right.

 

I've heard those push locks can be a problem so with my air in the system troubles I started improving everything and getting rid of those and reclamping/ tightening clamps, everything. I was seeing slow improvements till finally I got it.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...