Jump to content

Code problems p0238 p0112 p0521


Recommended Posts

I have 2001 dodge 2500 cummins and I keep getting this pain in the butt p0238 code. What could be the causes of this.

For the other codes I've already replaced the sensors but yet they are still illuminated I'm new to the diesel life so shine some light on this problem thanks!

Link to comment
Share on other sites

Welcome to the forum! I would start by doing the testing in these here articles. I'm not sure if you have read these yet or not... I will say this. It don't always work to just by new parts without fully testing first. I personally have learned that the hard way. Lol. I would also clean all your grounds and just keep an eye out for shorts in the wiring. 

And if you don't mind please fill out your signature with details and mods of your truck over in the account settings area. Thanks!

Link to comment
Share on other sites

4 minutes ago, Brandon.s said:

So I'm messing with the map sensor and it's read 3.42 and jumping 4.74 consistent with the truck no running is this normal or is it suppose to stay at a set voltage

I don't know a whole lot about it but go thru the testing section and I think it will tell you what your asking. Hopefully someone else will chime in and help you out. Sorry I don't know more than I do Haha. 

Link to comment
Share on other sites

FSM  page 14-103.image.png.52c2a0f798e1fab5c03efdcc76218b93.png

It will vary voltage in relation to manifold pressure.   Seems a bit odd that it reads 3.4v on low end.   A couple other guys will chime in with decent ranges for the voltage versus manifold pressure.

 

HTH

Hag

Link to comment
Share on other sites

  • Administrator
3 hours ago, Brandon.s said:

So I'm messing with the map sensor and it's read 3.42 and jumping 4.74 consistent with the truck no running is this normal or is it suppose to stay at a set voltage

That's WAY too much of a jump.  It should stay very stable engine off.  Does the 5V source wire have steady and good 5v?  

 

Does the ground have steady 0.00 resistence to ground?  

 

If both are yes then get a Cummins Map sensor.  

 

I believe all 3 of those sensors are on the same 5v buss so you might have an issue in the ecm, or the wiring leading to the sensors.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...