Jump to content

We have detected that you are blocking our advertisers. We pay our operational bills with advertising and donations. Please add Mopar1973Man.Com to your whitelist of sites on your adblocker. If you register as a member and submit a donation to the website, the advertising amount is reduced the more you donate. 

 

whitelist.png

 

This will allow you to keep you adblocker turned on for other sites and allow to display advertising here. Thank you, for understanding and whitelisting Mopar1973Man.Com. This will allow us to continue providing quality Cummins diesel information to everyone for free!

  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel forum. We are very friendly and helpful group of Dodge Ram Cummins owners. We will try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use. 

     

    Registration is free. Registering on the site will provide access to many more things like...
     

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members. Post up your used parts and vehicles.
    • Member Garage where you can proudly display your vehicles and modifications that you have done to them.
    • Download files, documents, and Quadzilla Adrenaline tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.
    • Reduced Advertisements displayed to you.

Recommended Posts

Here is the tune I am running...

POWER LEVEL 15

RPM LIMIT 3700

MAX VALET MODE POWER 15%

MAXIMUM FUEL STRETCH 2200

TPS PUMP MAX 100%

TPS PUMP MIN 0%

MIN PUMP TAP FUELING %  50%

PUMP LOW BOOST SCALE  20PSI

BOOST SCALING 20PSI

MAX LOAD TIMING OFFSET 2.0°

LOW PSI TIMING REDUCT 3.0°

TIMING REDUCT SCALING 0%

LIGHT THROTTLE TIMING ADV 5.0°

LIGHT THROTTLE LOAD LIMIT(PRESET)30%

RPM TIMING MAX 13.0°-16.0°-22.0°-24.0°-28.0

(0PSI 100)(1PSI 102)-(30PSI 146) increaseing by 2 from 0PSI TO 30PSI.

iQuad-2018-04-28-08.06.02.csv

Share this post


Link to post
Share on other sites

Give us some more information on the truck. 

 

Your tune even for a stock truck is rather over fueled. 

 

Max pump stretch need to come down. I'm only using 1200 to 1600 with 75 HP injectors. 

Min pump tap needs to come down. Way too much fuel typically most of us leave it at zero.

Boost scaling should be moved up to 30 to 40 PSI range. 

Light throttle timing is too much. Need to back down to 2 degrees. 

Timing reduct scaling should be 100%. With your current setting there is no reduction of timing and most likely over advancing. 

 

You might get better luck of using someone tune off the site. 

https://mopar1973man.com/files/category/22-quadzilla-standard-tunes/

Share this post


Link to post
Share on other sites

Sorry my post didnt all go on, my problem is when u running the truck hard in like 5th gear in a 6 speed at high rpm's. Like it starts cutting out around 3k rpm's and struggle to get to 3700. It will get there but it cuts out bad, u should be able to tell by the datalog and the fuel pressure sensor is hooked to drive pressure.

 

Im running

SO pump and had a Dragon Fire Extreme that did the same thing.

Mach 4 injectors that has SAC nozzles

425 studs and fire ringed

fass 150 that dont drop below 12 psi

HE351VE with fleece controler

 

I can run the TST COMP with Quad set on 3 and the tst turned up and it runs great all the way to 3700. I also got a 4k quad that runs good, ive ran different tunes and they all run fine on 4k. I need to hook the redline up and try it, The hardfuel box has always did this as far as i can remember i sent it to quad and had it tested and he ran it on his trucks and said it hesitateded at 3000 rpm's but he said it went to 3700, i think its something in the box that when it has a hard load on it, it trying to kick out. Its like u are turning the key off and on. The box runs fine long as u have it not doing wire tap. So i think its in the wire tap fueling on the quad that im having problems with.

 

I would like to let someone that has close to the same set up try it on there truck, i really like to get the box straightened out because im changing my set up with a bigger charger and going back to a bigger pump and bigger injectors, I like to have box working properly for the street So i can detune it. I hook to a sled 4-5 times so i run a aggressive tune.

 

Thanks

Share this post


Link to post
Share on other sites

back off wiretap from 2200 down to 1600, change min wiretap down to %0, increase boost scaling to 40 psi  

Timing:

1500:15*

2000: 19*

2500: 26*

3000: 28*

max: 30*

timing reduct scaling %100

 

 

You have enough injector to not need a ton of wiretap.  

 

Keep in mind the quad will fuel %100 to 3500 then from 3500 to 3700 the ecm is pulling fuel rapidly.  after 3700 rpm the quadzilla gives up.  

 

So you can spend prolonged time at 3450 rpm, but not at 3650  Trying to hold 3650rpm will result in fueling falling off and wiretap alone.     If you are accelerating through gears you can rev out to 3700 just fine, just not hold rpms in the 3500+ rpm area for prolonged periods of time.

Share this post


Link to post
Share on other sites

I understand the ecm wins but its doing it at 3000 rpm's, I will try the tune and report back.

Thanks

Share this post


Link to post
Share on other sites

I tryed that tune it lost a lot of power, I got the timing scale set to 100 and it ran fine with my tune. 

Thanks for the help

Share this post


Link to post
Share on other sites
Posted (edited)

start increasing fuel stretch until you are happy,  

 

with mach 4 injectors there is no need to have min wiretap set at %50 and fuel stretch at 2200.  You are going to produce less hp with stretch at 2200 than you will at 1800 or so.    Remember the butt dyno is a liar.

Edited by Me78569

Share this post


Link to post
Share on other sites

I''l play with it but im not sure why i had timing scale set at 0, i looked on my 4k tune and it was set at 100. Im going dyno this set up soon before i change set ups so i can see how it does.

thanks again

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×