Jump to content
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel forum. We are very friendly and helpful group of Dodge Ram Cummins owners. We will try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use. 

     

    Registration is free. Registering on the site will provide access to many more things like...
     

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members. Post up your used parts and vehicles.
    • Member Garage where you can proudly display your vehicles and modifications that you have done to them.
    • Download files, documents, and Quadzilla Adrenaline tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.
    • Reduced Advertisements displayed to you.

Recommended Posts

So I put a quadzilla on my truck today and I fell like it has more power but it wont smoke at all even on level 10 so I'm not sure of its hooked up right or maybe the wire tap to the pump isnt I. All the way I have no idea

Share this post


Link to post
Share on other sites

Default tune is rather limited. 

 

You need to build your own tune or dive into the download area and get a tune. Either way most of our tunes don't smoke. My daily tune is defueled pretty good on the starting edge for the fuel map. 

Share this post


Link to post
Share on other sites
Posted (edited)

you can't.   you should ditch the pod, it is old out of date tuning.    

 

Use a multimetere and test for 12v at the wiretap per the install directions. 

Edited by Me78569

Share this post


Link to post
Share on other sites

I got the v2 tuning on it I'm pretty sure I can buy the bt adaptors and switch it right? Do I check for 12v while running 

Share this post


Link to post
Share on other sites

you can't have v2 without the iquad.  or if you do the tune is just a generic safe tune.  You need to just swap the iquad.  

 

I dont remember off the top of my head, read the install directions.

Share this post


Link to post
Share on other sites

Check for 12v with the engine off but keyed on. It will set a code for MAP sensor voltage too low. Check for pin1 on the connector for 12v. 

 

Yes, you can just swap the iQuad out for the control pod. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×