Jump to content
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel forum. We are very friendly and helpful group of Dodge Ram Cummins owners. We will try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use. 

     

    Registration is free. Registering on the site will provide access to many more things like...
     

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members. Post up your used parts and vehicles.
    • Member Garage where you can proudly display your vehicles and modifications that you have done to them.
    • Download files, documents, and Quadzilla Adrenaline tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.
    • Reduced Advertisements displayed to you.

Recommended Posts

Trucks a 1998 dodge ram 3500 12v 47re so here is my issue the truck starts off in 3rd gear i can shift to 2nd manually but not 1st if I go to neutral then 1st it will go into first and the truck will only shift to overdrive and lockup sometimes but when it does it wont downshift unless I go to neutral then drive or down to 2nd my speedometer doesn't work sometimes it just bounces around or it floats up and down there are 4 codes that are coming up on the code reader i have attached a photo of the codes I just need help on what to buy to fix my problem im also including a photo of some kind of resistor on the pcm that the previous owner installed and some kind of overdrive controller that is on the truck as well as a noise isolator also in the pictures are the parts I think I need to buy to fix the truck

 

update 'm guessing the 2 tps codes are due to the overdrive switch because i had to unplug the tps to plug it in

 

update I went ahead and pulled the resistor out of the wire by the pcm and the speedometer started to work again and it seems to upshift from 3rd to od and back down now but still starts out in 3rd and I can still manually shift the rest I'm assuming the code is still there and causing limp mode so I disconected the batteries and turned on some electrical to drain all the power and will see if maybe that code goes away and if it will start in 1st pray for me

 

update. So went and drove still starts in 3rd shifts to OD around 40 then OD lockup around 55 speedometer works just can't seem to get truck to start in 1st or 2nd without manually shifting there has never been a cel light I will need to check codes tomorrow

 

truck is still showing same codes

Screenshot_2018-10-07-17-30-54.png

Screenshot_2018-10-07-17-39-59.png

Screenshot_2018-10-07-17-40-41.png

Screenshot_2018-10-07-13-55-25.png

Screenshot_2018-10-07-20-32-44.png

Screenshot_2018-10-07-20-37-10.png

Screenshot_2018-10-07-20-37-29.png

1008181756.jpg

Share this post


Link to post
Share on other sites

Maybe @Dynamic can help. He seems to be busy lately but he would know. Me, I know nothing of the auto tranny.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×