Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

Posted (edited)

So here’s the project: 1998.5 24v: ECM, PCM, engine harness, pcm harness, engine bay harness, and gauge cluster all 1998.5 from same truck. The cab/ dash harness is a 2001 gasser. My gauges power up fine, shows rpms but nothing else. Gauges appear to pass self test. Codes 920, 921. DOES NOT give me a NO BUS... 

 

I installed my brothers 1999 pcm and no change, took my gauges and pcm to his truck: my pcm works and his gauges work in his truck, my pcm and my gauges work in his truck. His pcm and my gauges work in his truck.... 

 

So: I feel that the 2001 dash harness has different wiring than the 1998.5.... also my head lights don’t work properly. 

 

My question now: can I get a couple wiring diagrams of the main grey plug under the dash so I can move the wiring around to make this work or am I better off trying to get a 1999 dash harness and see if it works with my 1998.5 engine bay harness??? Thanks for any input and sorry for a long first post but I wanted to be thorough. 

Edited by RyanBelesky
I made mistake

Share this post


Link to post
Share on other sites

Yes it is. I like projects and I’m enjoying this one as well. From a bunch of reading that I’ve done, and from just over thinking my situation: I think I wanna try a 1999 dash harness and hope for the best. 

Share this post


Link to post
Share on other sites

I don't think it wiring but needing to change out both ECM and PCM to match the cluster. The PCM is the master computer, The instrument cluster is what provides the Bus Bias, then The ECM is the second computer. The problem is the PCM is running different software and sending messages the cluster does not understand. This is why there is no "NO BUS" message because it can see the bus but doesn't understand what is being said.

 

Share this post


Link to post
Share on other sites

Thank you for the reply- but I feel you mis-understood what I wrote tho: the ECM, PCM, & Gauge cluster are all from the 1998.5 24v as most of the wiring. The only wiring that isn’t 1998.5 is the 2001 dash harness. It is somehow different because there is one red with orange wire on the 01 dash harness (if I remember color right) that doesn’t match up with the 1998.5 PDC harness... there may be more but I haven’t dug that deep into it. I did notice that the CCD wires match up (but there’s 3 pair on the 1998.5 and 2 pair on the 2001. Thanks again. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...