Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

I think it’s one of my new injectors....found a couple washers on one of the old ones so I’m thinking I missed one...

 

However though my battery keeps draining if I don’t disconnect it after I pull the fuel system fuse and key....so it can’t be an injector can it?

Share this post


Link to post
Share on other sites

No on the injector. Not sure why you would find 2 on the old injectors unless you left one of the old ones in the last time you changed them.

I take it this was happening before changing the ignition swithc? Something is not cutting 12v to the engine. This is where it gets over my head.

Edited by dripley

Share this post


Link to post
Share on other sites

How do you get it to shut off?  

 

Check for power at fuse #9 on the left side of the dash.  There should be no power at the fuse with ignition off.  This fuse powers the PCM (pin#1) and the ECM (pin#5). 

Share this post


Link to post
Share on other sites

I will give that a try but for now I just pull the fuse for the fuel system then disconnect the batteries

 

Share this post


Link to post
Share on other sites

You have a first gen truck with a fuel shut off solenoid. They go bad sometimes. There is one wire going to it on the injection pump right where the fuel enters. Check the connection and/ or tap on the solenoid. If I remember fuel shuts off when no 12 volts are running to it.

 

Oh shoot I'm sorry I was looking at your sig, and saw you had a 93 :duh:

Edited by JAG1

Share this post


Link to post
Share on other sites

I don’t think an 01 has it,,..think that’s controlled through the computer but there might be a relay just haven’t had a lot of time to work on it yet

 

Share this post


Link to post
Share on other sites
10 minutes ago, Tymatthew said:

I just pull the fuse for the fuel system

Where is this fuse?  In the PDC or the left side of the dash and what number is it?

Share this post


Link to post
Share on other sites

There is a fuel system relay in the PDC. Pull it and the engine will shut down.

Share this post


Link to post
Share on other sites

Fuse #3 in the PDC sends power to the ECM (red/white wire pins #48 and #50) and to terminal #30 of the  Fuel pump relay in the PDC.   This fuse has battery power all the time.

Edited by IBMobile

Share this post


Link to post
Share on other sites

No, I was just letting you know what that fuse powers and what was effected by removing that fuse.  I would still start with checking for power at fuse #9 with the key in the off position.  There should be none. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...