Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

My fuel gauge never work since I got the truck so I went out bought a new Sending unit from rockauto.com couple days late I drop the tank took out the old install the new one Put the tank back up and turn on the truck and the fuel gauge was working great!! Till I had to go to the store I notice my needle would move up to full then back  to empty then stay in the middle the whole ride was like that so I fill up the tank to see if anything would change and nothing happen. Got in touch with rock auto told them that the sending was bad if they can send me a new one 

 

did the process again I took off I was told that the sending unit has a arrow on top and it has to be align with the arrow on the tank made sure it was prefect I put the tank back up and still doing the same thing I check the cables that was fine went to the junkyard pull out a cluster got it install and nothing still acting crazy.  
 

any ideas 

Edited by Dieselmonkey
Misspelled
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...