Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

2007 5.9 cut off while driving engine light flashing won’t turn over?


Recommended Posts

Posted (edited)

2007 ram 3500 5.9 Cummins. Driving home everything fine all of sudden just cut off check engine light flashing and won’t even turn over. Also no gear numbers lighting up. Just had transmission put in a week ago but everything has been running fine?

Edited by Wade16
Link to post
Share on other sites

I am not really that familiar with the automatic transmission operation on a 2007 truck, but I would recheck every electrical connection related to the recent transmission work that you had done.  It sounds like communication to the transmission has been lost.

 

- John

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...