Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Idles fine, sluggish response, no boost, no codes


Recommended Posts

Let me first start by saying this website is an incredible resource and I'm very grateful for all the great content yall provide. 

 

During the extended time at home during COVID, I did a few projects on the truck and now I'm having some issues. 

1) Installed a FASS 165 with G&R sump

2) Replaced my old nasty battery cables with a set from custombatterycables.com

 

After both the projects, I put everything back together and it starts and runs fine, but doesn't produce any boost and has a fairly sluggish response. There is a decent amount of smoke if I get much above 2000 rpms. I still have steady constant fuel pressure at around 18 psi with the new FASS. No check engine light, but ran an OBDII code reader and it didn't report any codes (it's a bluedriver code reader, bought it for this diagnosis as it seemed to have a good reputation, but I guess there could be a possibility that there are codes its not reading as I have nothing to compare it to at the moment). 

 

Prior to the above projects everything was great. I've been digging all though the internet and this site trying to find the cause of my problem and I just can't seem to come up with any solutions. From reading on this site, it sounds like there is a possibility it could be an issue with the MAP or data link sensor, which I tried to investigate but nothing appeared to wrong with it. 

 

Things I have tried/investigated:

-no obvious boost leaks

-no glaring issues with the data link or MAP sensor plugs or wiring 

-no OBDII codes

-turbo spins freely

-Unhooked the quadzilla but it still behaved the same

-rechecked my battery cable wiring and everything seems fine

-reflashed the quadzilla and reinstalled (everything the quadzilla reads appears normal)

 

-My next thought was to change the MAP sensor, but I was curious if there is any way to tell that it is bad vice just blindly replacing.

-Also have dealt with bad injector pumps in the past, so understand that this could be a culprit, but ever since I got a new VP44 a while back when mine failed, I have had a raptor lift pump so I don't think (well really just praying) that the VP44 isn't the culprit. But if it was failing would there be codes/other symptoms to point here? seems like it's getting fuel so I haven't dug too deep into this. 

 

I'll take anything at this point as I'm currently stumped. Again, thank yall for the content and all the great information. 

Link to post
Share on other sites
Posted (edited)
12 hours ago, Mopar1973Man said:

P0237 or P0238 codes mist likely bad map sensor. If you have a Quadzilla you could watch boost signal compared to actual boost.

Ran it this morning, quadzilla shows 0 psi as well as my pillar boost gauge. All other quadzilla sensor readings appear normal. Is this indicative of a MAP sensor issue?

Edited by jstills
Link to post
Share on other sites
13 hours ago, jstills said:

Prior to the above projects everything was great.

 

Whenever I perform any work on my truck and something else doesn't work right after I am done, I always go back to "What did I inadvertently do to create this problem?"

 

First, I would retrace the steps taken when you when you worked on the fuel system and on the battery cables.

 

- John

Link to post
Share on other sites

If your pillar gauge and Quad are both saying 0 PSI then I think you got a problem with the turbo or a major boost leak (like a boot completely knocked loose). :stuned:

 

Your pillar gauge should get its pressure reading directly from the intake not the MAP sensor so with both of them reading 0 you really do have no boost.  Unless your pillar gauge decided to die at this exact time :think:

Link to post
Share on other sites
Posted (edited)

found the issue...not above admitting it even though I feel really dumb....like really dumb.

 

Don't forget to pull your rag out of your intake horn when you plug it to keep from dropping stuff in it....lesson learned

 

Appreciate the help and sound advice to retrace steps.

Edited by jstills
  • Haha 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...