Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Ironforger

Fuel Boss fuel pump unexpected high fuel pressures.

Recommended Posts

Posted (edited)
Fuel boss mechanical fuel pump . About 30k miles on it.
 
Lately i'm noticing random odd fuel pressure fluctuations, mostly pressure is occasionally going higher than expected, like 25+ psi. The strange thing about it is it seems to be happening when it shouldn't be like when I'm towing and revving at near wide open throttle  about 2500 rpm or above etc. I would think the pressure should be a little lower when the engine is demanding more fuel.
 
Other than that I can't find any rhyme or reason why this is occurring.
 
Any suggestions? Is this anything to worry about?
 
 
Thanks!
Edited by Ironforger

Share this post


Link to post
Share on other sites

The electric pumps spin at a constant rpm. More demand and the pressire will drop.

 

The mechanical pumps spin with engine rpm so they pump more fuel the higher the rpm.

Share this post


Link to post
Share on other sites
2 minutes ago, dripley said:

The electric pumps spin at a constant rpm. More demand and the pressire will drop.

 

The mechanical pumps spin with engine rpm so they pump more fuel the higher the rpm.

@dripley, right understandable but the issue im describing just started happening recently. Before that it was consistent  Fuel pressure: approx 17psi at idle. Cruising at 65mph: approx 19psi. WOT fuel pressure 17-18 psi.  Sometimes  upon letting off the throttle, the fuel pressure would go above 20psi, just momentarily.

 

So the issue I'm having now is kindof the opposite. It seems the pressure climbs up to 25+psi  randomly. 

 

Does this make any sense? 

 

Thanks

Share this post


Link to post
Share on other sites

I would verify the fuel pressure readings with a test gauge, could be in the gauge or sending unit itself, I’m not to sure about the mechanical gauge but electric ones have been known to give false readings sometimes. 

Might check your bypass valve, take it off and clean the plunger real good, could be sticking toward the closed side allowing pressure to rise a little 

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Ironforger said:

@dripley, right understandable but the issue im describing just started happening recently. Before that it was consistent  Fuel pressure: approx 17psi at idle. Cruising at 65mph: approx 19psi. WOT fuel pressure 17-18 psi.  Sometimes  upon letting off the throttle, the fuel pressure would go above 20psi, just momentarily.

 

So the issue I'm having now is kindof the opposite. It seems the pressure climbs up to 25+psi  randomly. 

 

Does this make any sense? 

 

Thanks

Kind of thought thats what you. The advice is agood place to start. Is your gauge mechanical or electric?

Share this post


Link to post
Share on other sites
3 hours ago, 01cummins4ever said:

electric ones have been known to give false readings sometimes. 

Might check your bypass valve, take it off and clean the plunger real good, could be sticking toward the closed side allowing pressure to rise a little 

 

Yea I removed the by-pass valve today and took it apart. Very simple device. It was clean, no debris and the plunger moves freely and springs back.

35 minutes ago, dripley said:

Is your gauge mechanical or electric?

 

It's electric. I have a needle valve inline to snub it down so it doesn't bounce erratically. I tweaked the needle valve a bit but made no difference.

 

Anyway thanks for the feedback guys. Leaving early in the morning, taking road trip  to Florida., towing my 20ft haulmark enclosed trailer with a 73 Buick Riviera inside. 

Share this post


Link to post
Share on other sites
10 minutes ago, Ironforger said:

Anyway thanks for the feedback guys. Leaving early in the morning, taking road trip  to Florida., towing my 20ft haulmark enclosed trailer with a 73 Buick Riviera inside. 

What part of Florida. I wiil just west of Jacsonville next week?

Share this post


Link to post
Share on other sites
Posted (edited)

Aww we don't have the emojis for the "this thread is pointless without pics"

 

Pics of the Riviera!

 

Hag

Edited by Haggar
  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, dripley said:

What part of Florida. I wiil just west of Jacsonville next week?

Ormond Beach near Daytona

10 minutes ago, Haggar said:

Pics of the Rivera

 

MVIMG_20200627_143624.jpg

  • Like 3

Share this post


Link to post
Share on other sites

NICE!

 

I love them.  I never had a boat tail, but wanted one so bad...  I had a couple Toronados (66 and 70) and an Eldarado (67)   Have always loved the Riviera  The first gen for dainty elegance, the second gen because  it looked a lot like the toronado and eldarado...  and the boat tail for it's unique look.   Also loved how GM wouldn't let Buick use the FWD platform of the Olds and Caddy, but Buick and Pontiac (think Grand Prix) did everything it could get away with to offer a Luxury/Sports car in the same size range. 

 

I was at Woodward a few years ago, and I ran into a fellow that had channeled his boat tail by about 4".  (channeling drops the body relative to the frame.... so the opposite of a "body lift")  I could not believe how good that looked!!! 

 

Hag

Share this post


Link to post
Share on other sites

Adjust your pressure down you are taking a risk of blowing out the front seal on the vp44. 20 psi is the max you want to see. The return port is small in the vp44 and can't return high volumes so the next thing that happen is the front seal pops out.

Share this post


Link to post
Share on other sites

Driving by Ormund Beach right now headed back towards Jacksonville.

 

My old boss right out of high school had a boat tail, frove that car quite a bit. He had a phone in it. Cool but strange back in 71.

 Maybe we can meet up this time. Let me know when you come thru.

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/28/2020 at 5:04 PM, 01cummins4ever said:

I would verify the fuel pressure readings with a test gauge, could be in the gauge or sending unit itself, I’m not to sure about the mechanical gauge but electric ones have been known to give false readings sometimes. 

Might check your bypass valve, take it off and clean the plunger real good, could be sticking toward the closed side allowing pressure to rise a little 

I agree with this.  These are the only 2 reasons this could happen...either a malfunctioning electric gauge or a malfunctioning check valve.  It sounds like you have already eliminated one of those...my money is on a bad gauge.  As with lift pumps a mechanical fuel pressure gauge is much better than an electric one.  Also put a strainer inline before check valve if you don't already have one...that will keep trash out of the check valve. 

Edited by Bullet

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...