Jump to content
  • Welcome To Mopar1973Man.Com

    We can see you are lurking about reading the forums and article databases. We happen to be one of the most friendliest Cummins support website on the planet. Come on and register and grab a inexpensive subscription plan. With that you can unlock even more for you. Technical support either by public forum, private support ticket, and even unlock phone support by Mopar1973Man. Mopar1973Man.Com will remain FREE to read forever!

Recommended Posts

  • Administrator

Man its been a weird month. Fuel gauge drops to empty comes back for a few days and quits for good. Find out the float wore out enough to slide all the way up the arm and let the arm sink to the bottom. Then had a ticking front on the passenger side come to find out passenger side wheel joint failed and the proceeded to break a clip and push the cap out will pull bushes out. About a month ago my cruise COAST button failed. I found a used switch on Maccari for $15 bucks, and installed it. Then last night figure I would play a bit on my performance tune and found out my wire tap isn't working (boost capped to 33 to 35 PSI). Most likely the tap screw loosen up a bit broke connection at the VP44.

 

So what I've got fixed...

  • Fuel gauge sender replaced
  • Passenger front wheel joint
  • Rear brake pads replaced (on pad rusted and separated)

 

 

Link to post
Share on other sites
  • Administrator

Mine is nearly zero'ed out I just got to fix my wire tap I just found out last night I can only make 35 PSI of boost with full wiretap which tells me to test the voltage on the tap. 

 

The next thing would be call the insurance company and have the body work repaired after my truck rolled off into a 4th gen back in Feb. It been a cluster mess with the title issue being Mom and Dad's name were on it. I managed to file for a new title while the COVID-19 lock down started. I got my new title already and now just need the time where I can give up my truck for the body work. I'm going to go forward with a complete paint job too. This is a low priority right now being I need the truck for work mostly. 

Link to post
Share on other sites

I'm still waiting on the head to get back. Shop said the valve guides are worn on all the exhaust. 

 

I'm not sure why, but the body on these trucks can be quite difficult to get all aligned into shape. I don't envy Moparmans body shop.

Link to post
Share on other sites

 I have some body work to do in the future as well. Mostly rust repair. Floor pan on the driver's side is the worst of it. If I catch the surface rust before fall I should be good there. Just hard to find time working full time to. Body work takes time and patience. I'm short on both these days.

Link to post
Share on other sites

I hear ya! My Blue chip pump I put in back in May has never worked right. When the exhaust break shuts off at about 25mph the engine idle drops way down then jumps up causing a jerk every time. Going from drive to reverse and vice versa the engine dies. Sometimes it will die slowing down for a turn. That’s always fun with no power steering. It only starts doing that when the outside temp gets above 85-90 degrees. Waiting on Doug to send me another pump. 

Link to post
Share on other sites
×
×
  • Create New...