Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

Hey everyone, my 08 megacab started surging after a head gasket was replaced, seems to be worse when hot out or going up long hills, just keeps cutting out briefly until temp goes down, got a programmer but I turn it off and never use it, just had the fass fuel pump replaced, still does it, any ideas?

Link to post
Share on other sites

Yes, I had to basically make him go drive it up the hill to see it was still surging, he said he didn't know other than to start " throwing injectors at it", he did the fass fuel pump, I put a solid fuel rail bolt in, next I'm gonna try putting a new back pressure sensor in and cleaning the line

Link to post
Share on other sites
  • Moderator

Take the solid fuel rail bolt out, it will cause long term issues. 

 

Have the crossover tubes been retorqued?

 

Do you have anything to monitor load, rail pressure (desired and actual), boost?

Edited by AH64ID
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...