Jump to content
  • Welcome To Mopar1973Man.Com

    We can see you are lurking about reading the forums and article databases. We happen to be one of the most friendliest Cummins support website on the planet. Come on and register and grab a inexpensive subscription plan. With that you can unlock even more for you. Technical support either by public forum, private support ticket, and even unlock phone support by Mopar1973Man. Mopar1973Man.Com will remain FREE to read forever!

Recommended Posts

So I've been trying to get my truck going, and it's been hell. 

I bought a set of 150hp injector tips, and used the pop tester at school to set the pop off pressures (all were at or just under 4500psi,stock recommended pressure), put them in along with new o-rings, and copper washers. 

I got the truck started, and it idles great. But as soon as I roll on the throttle, it pops, sputters, tons of smoke. Its been doing this, and I've pulled it apart about three times checking to make sure I didn't rip or tear any o-rings during assembly.  So far everything looks good, everything is torqued to spec. Fuel pressure is a steady 20 psi. 

Do I suspect the injection pump now? Or where else would you all recommend looking? 

I will say when the truck was running, every now and then it would sputter badly, and tons of white smoke would come out of the exhaust. If I turned the truck off then on again, it would clear up. I suspect the timing piston is seizing up in the pump, but I'm not 100% sure either. 

Thanks for the help! 

 

Link to post
Share on other sites

Quadzilla is unhooked, and the only codes it's throwing is the map and boost sensor codes because quadzilla isn't hooked up.

I talked to a local mechanic, and he suggested try a crankshaft position sensor? I did replace the camshaft position sensor whilst trying to diagnose this problem.

BTW, which sensor feeds the tach signal? Mine is working, but I'm just curious.

Link to post
Share on other sites
  • Administrator
On 9/22/2020 at 9:00 PM, Ravewolf said:

P0216 means it's dead, right? 

 

No longer capable of setting timing correctly in the given time. It will run still but the economy and power will be poor. Timing piston is more or less jammed and not moving properly any longer hence the code. More or less on a gas engine like taking the vacuum advance off a distributor and taking out the fly weights. Then set the distributor to a retarded timing and drive that. Power is low and economy is poor. 

Link to post
Share on other sites


×
×
  • Create New...