Jump to content
  • Announcements

    • Mopar1973Man

      Server Slowness & Strange behavior   03/15/2018

      I'm aware of the server and the site speed being weird. Might find strange server error messages and other things happening randomly. What I do know is the hard drive is hitting 100% load randomly and driving the server load up high. Then for no reason, the hard drive returns back to normal loads and server load drops. I've got the hosting company watching this and attempting to find a solution. I apologize for the performance issues... Thanks for understanding... 
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel forum. We are very friendly and helpful group of Dodge Ram Cummins owners. We will try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use. 


    Registration is free. Registering on the site will provide access to many more things like...

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members. Post up your used parts and vehicles.
    • Member Garage where you can proudly display your vehicles and modifications that you have done to them.
    • Download files, documents, and Quadzilla Adrenaline tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.
Sign in to follow this  

Inspection on the 96

Recommended Posts

Well Gang... I got the Cummins out of the shop and pull the 96 Gasser in to look it over and check fluids and such. Pull the spark plugs and check the gap and condition. Surprisingly the plugs where in excellent condition and only a few needed a bit of tweaking on the gap. I found a coolant leak and the surprise of it was I knew there was one because of the constant loss of coolant but couldn't see it. Then as the truck warmed up everytime you'd smell the sweet smell of coolant... Found it! The leak was on the corner of the intake manifold and the last bolt of the row was not exactly torqued tight... I'm planing on doing much more with this truck very soon... I'm planing on getting the trans shifting better with a new governor solenoid, ATF & filter change, band adjustment, etc... I want to get both of the truck around here working good. So now you might start seeing small write ups on Mopar V8 gasoline engines now too... :thumbup2:

Share this post

Link to post
Share on other sites

hey mike i am going to look at a 96 qclb tommorow witha v8 not sure 318 or 360 until i talk to the guy. its got plenty of extras and everything is supposed to work 122k on the clock. wants $2400. any thing out of the ordinary with yours i might keep an eye out for? thinking about dirving it until i can properly fix the 02.

Share this post

Link to post
Share on other sites

Nope nothing so far with ours... Just when you get a misfire code check your vacuum lines not the spark plugs...:lmao:

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this