Jump to content

Archived

This topic is now archived and is closed to further replies.

jumpjg

Check Gages Notification

Recommended Posts

New owner & still getting accustomed to my truck ('99 3500). I was reading another thread here in the 24v powertrain forum & the poster mentioned the check gauges notification coming on in his cluster, as if that was an indication of a problem. I noticed this notification on my truck; it will temporarily illuminate immediately after start-up (all gauges indicate normal), and will go out after about 5 seconds or so. I figured this was normal operation but after reading about all the troubles the other fellow was having I now wonder if it is. Is there anything I should be following up with?

Appreciate your patience & help,

Joe in St Louis

Share this post


Link to post
Share on other sites

Hey mine is the same way. It seems normal and runs fine though. Mine is not quite 5 seconds but maybe 3. It takes a second or two for my oil pressure to build up. I say MoparMan is right. or it could be "normal" especially if it goes out and stays out.

Share this post


Link to post
Share on other sites

mine usually does the same during cold starts, usually it is the oil pressure building(maybe a slow oil sending switch? :shrug:) i run valvoline with the "C" and donaldson endurance filter. it also does it when both grids are hitting for excessive time. it drops the volt-o-meter down to ~10volts and trips the light.

Share this post


Link to post
Share on other sites

Mine will do this when I make a turn faster than about 25 mph ...I first thought it was the batteries being loose but it still does it after the new battery hold downs where installed and I run shell rottella in the. The truck with a mopar oil filter

Share this post


Link to post
Share on other sites



×