Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
Mopar1973Man

Linux???

Recommended Posts

Hey Gang...I dove off the deep end and created a dual boot computer with Linux (CentOS) and Windows Vista. So far I'm enjoying the Linux over the Windows... It's nice not have to worry about anti-virus software, firewalls, etc... Linux is such a rock solid operating system and works wonderful. There is things I'm still learning about Linux like installing programs, and such but with a little time and reading I'll bone up on how to do it right... So far like as I post this message I'm fired up on the Linux stystem and its so much faster than Windows...:burnout2:

Share this post


Link to post
Share on other sites

Over my course of time with using windows, I have figured out you don't need all that antivirus crap. I have a little free one but I don't need it. I believe there is no way for a virus to just "get" on your computer. I think you get them when you click on links in emails or attachments or go to websites you shouldn't be at. With that said, you can always switch to windows 7 and it will be faster, at startup anyways. I put that SSD in my sisters laptop which is identical to mine and it sped hers way up...to the speed it takes 7 to start up on mine and I don't have an SSD. Now once the OS is loaded, hers just blows the doors off everything as everything is instant. You can click on any program that you have never used and it pops up instantly. You no longer need to defrag either. I don't know what vista does in comparison to 7 during startup, I disabled and deleted a ton of stuff on hers including many many services and all kinds of stuff but it still lets that scroll bar go across 5 times before going forward. There are many features that are really nice in 7 that aren't in vista as well. I would like to get an SSD with XP since it would pretty well start up without even showing the scroll bar I'm guessing. I never had any issues with XP unlike a lot of other people and I hate how vista and 7 always have to load network computers for 30 seconds before I can click on them. Post some screenshots of this linux thing.

Share this post


Link to post
Share on other sites

I'm no computer wizz... but I'm running XP home on both my desktop & laptop. I struggle so to learn new stuff, I really don't want to go through that. Originally my laptop didn't even have a intenet adaptor but I finally bought the plug in wireless adaptor. I just used it for meeting & took the data home on a thumb drive. I really don't want to replace my computers just because someone wants to sell me a new one.The wife got into digital photography & was filling up the memory on the desktop so I bought her a laptop (Vista)... but I stay away from it!

Share this post


Link to post
Share on other sites

@ISX Well let put it this way I'm still trying to learn how to install FireFox 4 here I'm currently running FireFox 3.6 and installing software isn't like Windows where you click setup.exe and keep clicking next ot the finish button. As for screen capture I'm not sure yet but I'll look for it. @Russ I wasn't trying to sell it to you but I figure I would more or less blog what I'm doing for fun. The funny part is this is the very same server software that is hosting this web site right now. :stuned: Yeap... CentOS is the OS that www.mopar1973man.com is hosted on. So I figure since CentOS is freeware I would download it and learn more about it and improve the site by understanding whats under the hood. Trust me I'm still playing with the power windows... :lmao::lmao2: In time I'll get the hang of it. I know without a doubt I will always have a Windows OS on this machine for other chours that Linux can't do. Sure is nice to see a freeware OS have just as much power if not more than Windows and it completely free. :thumb1:http://www.centos.org/ Desktop Style (I've got both styles loaded but slightly different in CentOS) http://www.gnome.org/gnome-3/ http://www.kde.org/screenshots/

Share this post


Link to post
Share on other sites

I'm a Linux and Windows Server admin. Linux, hands-down, out performs Windows my quite a margin. We've got a Linux server than has NEVER been rebooted in over 5 yrs. Yes, five years. Try that with a Microsoft OS. :lmao:

I have several laptops at home that are either dual-boot (Linux + WinXP, Linux + Win7) or Linux only (Ubuntu, Fedora 13, CentOS.) CentOS is near Identical to Red Hat (Fedora, or RHEL for server). It's not a click-n-go, like Winblows OS, but is much more reliable, faster, uses far less resources, etc.

Anti-Virus is almost a must for MS OS, ISX. Virii can be triggered by simply clicking on a picture, java, flash, etc. since 80% of the universal people run MS-based OS (the other 20% is comprised of Apple and Linux), hackers go with the masses.

--- Update to the previous post...

...and I like the new Gnome3.

ISX - SSDs are awesome, but the pricing is still way up there, mainly due to their newness. Kinda like an LED light for the home.. Once the new wears off, their pricing will drop. Like the $49 iPhone 3GS.. :duh:

Share this post


Link to post
Share on other sites

Just what I wanted to hear Rogan... :hyper: Now since you do have expereience with Linux could you explain how to install apps like for example like FireFox 4. The whole RPM, Yum, etc is confusing a newbie. :banghead: Lets say I'm wanting t oswitch over to Linux on my network here and use Windows as a secondary OS system only on my computer. Since MoparMom is just a web surfer she could get along with Firefox easy. I've been researching some of my software I use and finding either Linux (look alikes) or a Linux version of the same software so its looking like a much stronger market for linux than about 5 years ago when there was hardly nothing for it. But Rogan would you please school this dummy on how to install apps (CentOS). :doh:

Share this post


Link to post
Share on other sites

yep, looks just like Fedora 13.

do you have YUM installed? RPM? what are these?

The Red Hat Package Management system (RPM) is an installation application that makes installation, uninstallation, verification, and querying programs simple, while retaining the common strengths and efficiency of Linux.

Yum is an interactive, automated update program which can be used for maintaining systems using rpm by super users (root).

Yum will work only from CentOs 5 / Redhat 5 and latest versions of fedora. For Old releases like Rhel 4 you need to use up2date command to update your rpm based packages.

_________________________________________________

FireFox 4:

Firefox 4 Installations for Fedora 14 Laughlin

Run terminal, then type

yum --enablerepo=remi update firefox

Firefox 4 installations for Centos and RHEL

Firefox 4.0b8 worked on CentOS 5.5, but 4.0b9 has a problem with the revision of the C++ library and won’t run out of the box. All is not lost though, because you can use Fedora 9′s C++ library instead as follows (some of this may need sudo/root access):

1. Unpack the Firefox 4.0b9.tar.bz2 somewhere (e.g. /usr/local/firefox). With the “en_GB” release, I throw in a “dictionaries” sub-dir under there with en-GB.aff and en-GB.dic in there (and en-US.aff/.dic soft-linked to the en-GB ones) otherwise, sadly, Firefox 4 uses US spellings on what’s supposed to be an en_GB release Posted Image

2. Download this 32-bit Fedora 9 libstdc++ RPM and unpack it with this command:

rpm2cpio libstdc++-4.3.0-8.i386.rpm | cpio -i –make-directories

3. Move the unpacked shared library into /usr/local/firefox thus:

mv usr/lib/libstdc++.so.6.0.10 /usr/local/firefox/libstdc++.so.6

Note: It’s “usr/lib/libstdc++.so.6.0.10″ above (i.e. the unpacked tree from the RPM, not the system /usr/lib tree) – do NOT put a leading slash there!

4. Run Firefox 4.0b9 with:

/usr/local/firefox/firefox

Or you can install last stable release of firefox from Here and compile with installations instructions on readme file.

This’s the English version of Firefox 4.0 for other languages install suitable extensions 32bit, 64bit.

Centos and RHEL installations instructions Source

http://www.linuxnov.com/install-mozilla-firefox-4-on-fedorarhelcentos-using-remi-repository/

--- Update to the previous post...

Use list command to see list of updates available:

#yum list updates

Use update to apply all recent updates available

#yum update

Use list with installed to list all installed packages

#yum list installed

Note: If you know package names you can use

#rpm -qa to list

For example; If you want to know which version of mysql is installed on your system Use

# rpm -qa|grep mysql

Alternatively you can use

#yum list |grep mysql

If you want your architecture specific packages you can try patterns like

# yum list|grep mysql.`uname -i`

Once you know what version you have and if you want to update specific package

Use

#yum update {package_name}

You can also update multiple packages seperated by space at the same time

#yum update {package_name_1} {package_name_2}

In the same way you can install multiple packages using install

#yum install {package_1} {package_2}

Use remove to remove packages; For example to remove mysql

#yum remove {mysql_package_name} OR #yum remove mysql*

One more nice feature Yum has is group listing; suppose if you want to install all multimedia

extras or comple set of mysql database or all development tools we can use group.

#yum grouplist — Used to list all avaialble groups

Afer that its simple

#yum groupinstall {group_name} (ex. #yum install “Development Tools”)

Same way you can update group

#yum groupupdate “Development Tools”

Apart from all above sometimes we need to install packages from third party repositories,

to do so you need to first add that third party repositories to your list of repos. Follow bellow

steps to easyly add repos

Find out which repository you want to add and grab the repo url from internet

Example: Suppose If you want to add rpmforge

Way 1: Install RPM forge packages to map repository information

#wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.1-1.el5.rf.x86_64.rpm

#rpm –import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt

#rpm -i rpmforge*.rpm

#yum check-update

OR

Way 2: Install repo by adding repositories using repo file. This is the standard way of adding

third party repositories to your Yum.

Go to yum.repos.d

#cd /etc/yum.repos.d

Create new file for rpm forge

#vim rforge [note: file name really doesn't matter; but its always better to follow naming]

add following lines

[rforge]

name=RPMForge for RHEL/ CentOS $releasever – $basearch

baseurl=http://rpmforge.net/centos/$releasever/$basearch/

enabled=1

gpgcheck=1

gpgkey=http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt

Where

rforge: Repository Name

name: Human readable name for the main name i.e for rforge

baseurl: Must be a valid url of the repositories metadata i.e repodata location

enabled: used to enable or disable

gpgcheck: Its a security feature for GPG key

gpgkey: GPL file location

After this import the above specified gpl file using rpm -import

#rpm –import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt

And thats it , form now on wards your yum will start scaning rpmforge for update when ever you use.

--- Update to the previous post...

Mopar Icon Notes
NEXT

You can also get switches and general info for commands, such as YUM/RPM as examples, from within the terminal window.

[rwall@DBserver1 ~]$ man yum       While  there  are  some  graphical interfaces directly to the yum code,       more recent graphical interface development  is  happening  with  Pack-       ageKit and the gnome-packagekit application.       command is one of:        * install package1 [package2] [...]        * update [package1] [package2] [...]        * check-update        * upgrade [package1] [package2] [...]        * remove | erase package1 [package2] [...]        * list [...]        * info [...]        * provides | whatprovides feature1 [feature2] [...]        * clean [ packages | headers | metadata | dbcache | all ]        * makecache        * groupinstall group1 [group2] [...]        * groupupdate group1 [group2] [...]        * grouplist [hidden] [groupwildcard] [...]        * groupremove group1 [group2] [...]        * groupinfo group1 [...]        * search string1 [string2] [...]        * shell [filename]        * resolvedep dep1 [dep2] [...]        * localinstall rpmfile1 [rpmfile2] [...]        * localupdate rpmfile1 [rpmfile2] [...]        * reinstall package1 [package2] [...]        * downgrade package1 [package2] [...]        * deplist package1 [package2] [...]        * repolist [all|enabled|disabled]        * help [command]       Unless the --help or -h option is given, one of the above commands must       be present.       Repository configuration is honored in all operations.       install              Is used to install the latest version of a package or  group  of              packages while ensuring that all dependencies are satisfied.  If              no package matches the given package name(s), they  are  assumed              to  be  a  shell glob and any matches are then installed. If the              name starts with an @ character the rest of the name is used  as              though  passed  to  the  groupinstall  command. If the name is a              file, then install works like localinstall. If the name  doesnât              match  a  package,  then  package  "provides"  are searched (Eg.              "_sqlitecache.so()(64bit)")    as     are     filelists     (Eg.              "/usr/bin/yum").  Also  note  that for filelists, wildcards will              match multiple packages.       update If run without any packages, update will update every  currently              installed package.  If one or more packages or package globs are              specified, Yum will only  update  the  listed  packages.   While              updating  packages,  yum  will  ensure that all dependencies are              satisfied. If the packages or globs specified match to  packages              which  are  not currently installed then update will not install:  
The colon at the end means there's "more" to read.

[*]

[list]

[*]The Return key will advance you line by line.[*]Space Bar = Page Down[*]q is QUIT

[rwall@DBserver1 ~]$ man rpmRPM(8)                           Red Hat Linux                          RPM(8)NAME       rpm - RPM Package ManagerSYNOPSIS   QUERYING AND VERIFYING PACKAGES:       rpm {-q|--query} [select-options] [query-options]       rpm {-V|--verify} [select-options] [verify-options]       rpm --import PUBKEY ...       rpm {-K|--checksig} [--nosignature] [--nodigest]           PACKAGE_FILE ...   INSTALLING, UPGRADING, AND REMOVING PACKAGES:       rpm {-i|--install} [install-options] PACKAGE_FILE ...       rpm {-U|--upgrade} [install-options] PACKAGE_FILE ...       rpm {-F|--freshen} [install-options] PACKAGE_FILE ...       rpm {-e|--erase} [--allmatches] [--nodeps] [--noscripts]           [--notriggers] [--repackage] [--test] PACKAGE_NAME ...   MISCELLANEOUS:       rpm {--initdb|--rebuilddb}       rpm {--addsign|--resign} PACKAGE_FILE ...       rpm {--querytags|--showrc}       rpm {--setperms|--setugids} PACKAGE_NAME ...   select-options        [PACKAGE_NAME] [-a,--all] [-f,--file FILE]        [-g,--group GROUP] {-p,--package PACKAGE_FILE]        [--fileid MD5] [--hdrid SHA1] [--pkgid MD5] [--tid TID]        [--querybynumber HDRNUM] [--triggeredby PACKAGE_NAME]        [--whatprovides CAPABILITY] [--whatrequires CAPABILITY]   query-options        [--changelog] [-c,--configfiles] [-d,--docfiles] [--dump]        [--filesbypkg] [-i,--info] [--last] [-l,--list]        [--provides] [--qf,--queryformat QUERYFMT]        [-R,--requires] [--scripts] [-s,--state]        [--triggers,--triggerscripts]   verify-options        [--nodeps] [--nofiles] [--noscripts]        [--nodigest] [--nosignature]        [--nolinkto] [--nomd5] [--nosize] [--nouser]        [--nogroup] [--nomtime] [--nomode] [--nordev]   install-options        [--aid] [--allfiles] [--badreloc] [--excludepath OLDPATH]        [--excludedocs] [--force] [-h,--hash]        [--ignoresize] [--ignorearch] [--ignoreos]        [--includedocs] [--justdb] [--nodeps]        [--nodigest] [--nosignature] [--nosuggest]        [--noorder] [--noscripts] [--notriggers]        [--oldpackage] [--percent] [--prefix NEWPATH]        [--relocate OLDPATH=NEWPATH]        [--repackage] [--replacefiles] [--replacepkgs]        [--test]:
Just examples, as DOS window has 'help' or '?', etc..

Share this post


Link to post
Share on other sites

Here you go Rogan... I managed to install Opera Browser easy as pie. Opera has a INSTALL file you run in the terminal and follow along with the screen like windows. So now I got a browser that works good now. Also now I got a clue on what to look for on installing software.

Now got a question I installed Opera to usr/local/opera directory is this correct spot ot put software? :shrug:

--- Update to the previous post...

Holy cow Rogan you going to have to slow down a step or two and explain the has you posted... :banghead:

Share this post


Link to post
Share on other sites

Opera is decent :)

Some web pages may not function/display properly, but it's a start!

Probably /usr/local/ is best. It depends on whether you plan to make it available to all users or only to one, when you install apps. If it goes to /home/USERNAME it will be available only to user USERNAME and root. If it is in /usr/local it will be globally available.

I think you should install all apps in /usr/local, unless there's an app only you will need/use...

--- Update to the previous post...

[rwall@DBserver1 ~]$ top

displays the 'task manager' of linux..

Once it's displaying (real time) you can use the B(bold) and Z(color) to change the display.

CTRL+C closes it and takes you back to the prompt.

Share this post


Link to post
Share on other sites

I have been running Ubuntu and ran other distributions in the past. I have been running linux since about 1998. I also dual boot windows. Currently I am running Windows XP on my other partition.I am also running a custom version of Ubuntu on another old computer that I intend to use for CNC milling. It is called EMC2 or Enhanced Machine Controller.As for browsers I am using Chrome at the moment on both Ubuntu and Windows and it seems to be working well for me. Occasionally I hit a snag and revert back to Firefox.

Share this post


Link to post
Share on other sites

More and more I play with Linux the more I'm starting to like it. There is thing that are difficult to grasp but I'm continuing to read and trying to learn how it all works. So if you guys have some things to help me out I'm all ears to learning...

Share this post


Link to post
Share on other sites

Holy cow Rogan you going to have to slow down a step or two and explain the has you posted... :banghead:

you asked for it! :lmao:

More and more I play with Linux the more I'm starting to like it. There is thing that are difficult to grasp but I'm continuing to read and trying to learn how it all works. So if you guys have some things to help me out I'm all ears to learning...

I do like Linux, but if you're used to certain apps in a MS environment (i.e. Photoshop, Corel, etc.) Gimp doesn't cut the mustard LOL

a bunch of Linux apps and functionality are cumbersome for the end-user who is used to having easy-to-operate applications, as Linux isn't as 'user-friendly' as the MS or Apple venues are. But with some persistence and a little time + dedication, you'll be fine.

and TERMINAL, from an OS standpoint, is phenomenal. It's so powerful.

I'm starting to sound like a...

...Posted Image

Share this post


Link to post
Share on other sites

Yeah I can see the horsepower in the software its just a matter of having a good set of documents to lead you through the nightmare of learning linux. I can see it was well designed and very secure product. But when you looking in the Help on installing a program you can find nothing because the syntax of Linux is all different. It's like learning a whole new language first before being able to even run the software. So I'm at the point of just beating the trash out of this CentOS and findout what works and what doesn't. Play with till I break it then re-install and do it again. Eventually I figure it out...

Share this post


Link to post
Share on other sites

Windows guts: basically unchanged since windows NT 3.1 (c.1993)

Linux: Many variations

[*]Debian-based

[*]Knoppix-based

[*]Ubuntu-based

[*]Official distributions

[*]Contributed distributions

[*]Third-party distributions

[*]Gentoo-based

[*]Pacman-based

[*]RPM-based

[*]Fedora-based

[*]Red Hat Enterprise Linux-based

[*]Mandriva Linux-based

[*]Slackware-based

[*]Slax-based

[*]Others

...and they all have a different way (for the most part) of accomplishing the same thing, context/syntax-wise..

Share this post


Link to post
Share on other sites

CentOS (Community Enterprise Operating System) is, in a nutshell, Red Hat/Fedora. CentOS5 Server is basically RHEL5 (Red Hat Enterprise Server.) CentOS GUI is essentially Fedora. It's built from the RH source code, and is the most used Linux distro for web servers.

RHEL/CentOS is rpm-based. I use YUM and RPM for installations.

There are several front ends to RPM that ease the process of obtaining and installing RPMs and in resolving their dependencies. These include:

[*]yum used in Fedora, MeeGo, CentOS-5, Red Hat Enterprise Linux 5 and above, Scientific Linux, Yellow Dog Linux and Oracle Linux.

[*]up2date used in Red Hat Enterprise Linux and CentOS (CentOS-3 and CentOS-4).

Local RPM installation database Working behind the scenes of the package manager is the RPM database, stored in /var/lib/rpm. It uses Berkeley DB as its back-end. It consists of a single database (Packages) containing all of the meta information of the installed rpms. Multiple databases are created for indexing purposes, replicating data to speed up queries. The database is used to keep track of all files that are changed and created when a user (using RPM) installs a package, thus enabling the user (via RPM) to reverse the changes and remove the package later. If the database gets corrupted (which is possible if the RPM client is killed), the index databases can be recreated with the

rpm --rebuilddb
command.

An RPM is delivered in a single file, normally in the format:

<name>-<version>-<release>.<architecture>.rpm
such as:

libgnomeuimm-2.0-2.0.0-3.i386.rpm
Source code may also be distributed in RPM packages; the architecture part is specified as <src>:
 libgnomeuimm-2.0-2.0.0-3.src.rpm
RPMs with the noarch.rpm extension refer to packages which do not depend on a certain computer's architecture.

The RPM contents also include a package label, which contains the following pieces of information:

[*]the software name

[*]the software version (the version taken from original "upstream" source of the software)

[*]the package release (the number of times the package has been rebuilt using the same version of the software). This field is also often used for indicating the specific distribution the package is intended for by appending strings like "mdv" (formerly, "mdk") (Mandriva Linux), "fc4" (Fedora Core 4), "rhl9" (Red Hat Linux 9), "suse100" (SUSE Linux 10.0) etc.

[*]the architecture the package was built for (i386, i686, athlon, ppc, etc.)

The package label does not necessarily need to match the name of the file.

Never log in/work in ROOT.. Never make your user account match ROOT privs. Use SUDO command.

From terminal, to run an installation, patch, etc., the command would be something like this:

[rwall@APPserver1 ~]$ sudo su - root[root@APPserver1 ~]# ls -lhtotal 512M-rw------- 1 root root 1.8K Feb 28  2010 anaconda-ks.cfg-rw-r--r-- 1 root root 1.1K Jul 20  2010 banner.txt-rwxr-xr-x 1 root root  11K Oct  7  2010 [COLOR=lime]bootstrap-V5.x86-64.TDL.sh[/COLOR]-rw-r--r-- 1 root root  621 Jun 30  2009 client-config-overrides.txt-rw-r--r-- 1 root root 8.1K Jun 11  2009 client_config_update.pydrwx------ 2 root root 4.0K Nov  1  2010 Desktop-rw------- 1 root root  883 Nov  1  2010 id_rsa-rw-r--r-- 1 root root  42K Feb 28  2010 install.log-rw-r--r-- 1 root root 3.7K Feb 28  2010 install.log.syslog-rw-r--r-- 1 root root  42M Oct  9  2009 [COLOR=red]jdk-1_5_0_22-linux-amd64.rpm[/COLOR]-rwxr-xr-x 1 root root  42M Oct 18  2010 [COLOR=lime]jdk-1_5_0_22-linux-amd64-rpm.bin[/COLOR]-rwxr-xr-x 1 root root  80M Sep 16  2010 [COLOR=lime]jdk6.22.bin[/COLOR]-rw-r--r-- 1 root root  20M Sep 16  2010 jre-6u22-linux-x64.bin?e=1287602650&h=c18240779380336df45da762a956dfa9-rwxr-xr-x 1 root root 302K Oct 18  2010 [COLOR=lime]webapp1015.dmp.gz[/COLOR]-rw-r--r-- 1 root root  27K Dec  3 16:31 PROD_Installed_Packages.txtdrwxrwxrwx 6 root root 4.0K Nov 24 16:20 [COLOR=blue]RHEL5.5[/COLOR]-rw-r----- 1 root root 1.1K Mar 28 13:39 var.df-rw-r----- 1 root root 5.0K Mar 28 13:39 var.du[root@mwniuw1 ~]#
To exit ROOT and return to your user acct, CTRL+D

ls -lh = List (or Dir), -l = long, h = display size in MB form. you can see the different views by trying it as:

[*]# ls

[*]# ls -l

[*]# ls -a

As for the "ls" colors:

[*]Executable files: Green

[*] Normal file : Normal

[*] Directory: Blue

[*] Symbolic link : Cyan

[*] Pipe: Yellow

[*] Socket: Magenta

[*] Block device driver: Bold yellow foreground, with black background

[*] Character device driver: Bold yellow foreground, with black background

[*] Orphaned syminks : Blinking Bold white with red background

[*] Missing links ( - and the files they point to) : Blinking Bold white with red background

[*] Archives or compressed : Red (.tar, .gz, .zip, .rpm)

[*] Image files : Magenta (.jpg, gif, bmp, png, tif)

[root@APPserver1 ~]# ls -lh[rwall@APPserver1 ~]$ sudo su - installer[nios@APPserver1 ~]$ ls -lhtotal 64Mdrwxrwxr-x  2 installer installer 4.0K May  4 08:57 [COLOR=blue]backup[/COLOR]drwxrwxr-x  6 installer installer 4.0K Apr  7 15:58 [COLOR=blue]deploy[/COLOR]-rwxrwxrwx  1 installer installer  64M Apr  7 15:51 [COLOR=lime]deploy.zip[/COLOR]-rwxrwxrwx  1 installer installer  970 Apr  7 15:51 [COLOR=lime]ins.sh[/COLOR]drwxrwxr-x 12 installer installer 4.0K Jun  3  2010 [COLOR=blue]jboss-4.0.5.GA[/COLOR]drwxr-x---  9 installer installer 4.0K May  4 07:26 [COLOR=blue]logs[/COLOR]drwx------  2 installer installer  16K Oct 20  2010 [COLOR=blue]lost+found[/COLOR]drwxrwxr-x  2  512 installer 4.0K Apr  8 14:10 [COLOR=blue]iinstallerdailybackup[/COLOR]-rwxrwxr-x  1 installer installer 1009 Apr 29 11:34 [COLOR=lime]appLogCopy[/COLOR]-rwxrwxrwx  1 installer installer  825 Apr 28 11:09 [COLOR=lime]apprestart[/COLOR]drwxr-x---  5 installer installer 4.0K May  4 07:38 [COLOR=blue]patch-S22-0503[/COLOR]drwxr-x---  2 root root 4.0K Mar 28 15:02 [COLOR=blue]ssl_error_log-backup[/COLOR]drwxrwxr-x  2 installer installer 4.0K Apr  1 14:45 [COLOR=blue]tmp-04011[/COLOR]1[nios@APPserver1 ~]$[I]{CTRL+D}[/I][root@APPserver1 ~]#
In the above example list, ins.sh is kinda like a .inf or .ctl file (control file). It contains what to do with the deploy.zip file. To install the deploy.zip, the command is simply:

[nios@APPserver1 ~]$ ./ins.sh
The installation will take place, and is visible in the Terminal window, as the information scrolls through..

/usr/bin/ls Contains the ls command.

/etc/passwd Contains user IDs.

/etc/group Contains group IDs.

/usr/share/lib/terminfo/* Contains terminal information

Warning Icon WARNING!
NEXT

[nios@APPserver1 ~]$ ls -lh total 64M-rwxrwxrwx 3 nios nios 15.0K May 4 07:25 testfile drwxrwxr-x  2 installer installer 4.0K May  4 08:57 backup drwxrwxr-x  6 installer installer 4.0K Apr  7 15:58 deploy -rwxrwxrwx  1 installer installer  64M Apr  7 15:51 deploy.zip -rwxrwxrwx  1 installer installer  970 Apr  7 15:51 ins.sh drwxrwxr-x 12 installer installer 4.0K Jun  3  2010 jboss-4.0.5.GA drwxr-x---  9 installer installer 4.0K May  4 07:26 logs drwx------  2 installer installer  16K Oct 20  2010 lost+found[nios@APPserver1 ~]$
the drwxrwxrwx stuff at the front of each entry shows the permissions for that file/directory/etc..

It's binary for 777 octal number, sorta.. The first one will usually be a 'd' or '-'. This denotes a Directory or file. There are other indicators for this slot, as well, but we'll cover that later. Each 7 denotes permissions to

so, 777, or 111 111 111. You know binary/octet placement, correct? 4-2-1?

7 = 4(1) + 2(1) + 1(1)  = FULL (read + write + execute)6 = 110 = read + write5 = 101 = read + execute4 = 100 = read only3 = 011 = write + execute2 = 010 = write only1 = 001 = execute only0 = 000
each binary digit for an octal placement corresponds to a right granted.

so if a file is: -rwxrwxrwx , the rights for that file are ®ead (w)rite (x)ecute. If it were a directory, then it would display as: drwxrwxrwx

in this same example, Mike, if you wanted to change the permissions on the file (you must 'own' the file in order to do so, indicated by owner=nios group=nios) the command is:

[nios@APPserver1 ~]$ chmod 444 testfile
This would change that file's permissions from

-rwxrwxrwx

to

-r--r--r--

effectively making it a read only, for everyone. Make sense, kinda?

Share this post


Link to post
Share on other sites

Right now I have a dual boot of Windows 7 and Ubuntu, and the main reason I even have windows is so I can play all my PC games. That being said I've installed and tried many distros of linux in my search for the one that best suites me. I've found that Ubuntu is my favorite simply because it just works, and if you want to install a program they made it super easy compared to some of the other distros that I've tried, all you have to do for most software is just search for it in the built in "add/remove" programs menu and click install. Quick and easy, just how I like my computers :)

Share this post


Link to post
Share on other sites

Ubuntu is a nice distro. Proven with a great track record. and 99% of the time, all hardware works (incl. wireless on a laptop.) I actually think I've got Ubuntu 3 on a cd somewhere LOL Mike, there's an app called WINE (www.winehq.com) that will often allow a Windows-based app to run on a Linux box, much like Parallels for Mac.

Share this post


Link to post
Share on other sites

Well I done screwed up really good this time... :doh: I screwed up linux playing around and thought just re-install and all will be good again. I forgot to set the boot drive in BIOS so when the install ran it installed on the drive for linux but it re-wrote the boot sector on my windows drive. :banghead: After fighting with it for a while and getting the boot sector recovered then I managed to install it properly so GRUB is now my boot loader for both Windows (default) and Linux. So now I can flip flop back and forth... Still having problems with installing software like Java, Adobe flash, etc... Always seem like there is something new and different by each software designer. Rather annoying. What is worse is the instructions on installing never work for me... :duh: Then when I get it to work then I wonder did I install in the right folder? Most times not... Frustrated but still trying to learn... Like I think I figured out *.bin is like windows *.exe files... (Not sure)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...