Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

I always thought the P1689 code meant the electronics failed in the VP?

Share this post


Link to post
Share on other sites

I always thought the P1689 code meant the electronics failed in the VP?

Not always... I've seen now...

[*]Bad ECM cause a P1689

[*]Bad Fuel Pump relay in the PDC cause a P1689

[*]Bad driver side ground cause a P1689

And a few more I can't remember right now...

Share this post


Link to post
Share on other sites

OK Time for an update:The 99 had the harness rung out between the ECM connector and the FPCM connector. no problems found. Reassembled using Stabilant 22 on all pins; Swapped the horn and fuel pump relays; I also put in a new fuel filter since it was apart to access the ECM connector. Fired right up' no codes. I will monitor for codes (the Actron OBDII monitor is sitting on the seat) the 92 is running fine, I am just leery of a 400K tranny. - found the electrical prob with the power windows so it can be driven in SC without AC now. It received a full fluid maintenance today

Share this post


Link to post
Share on other sites

Too much restriction or air leak... You got to go back over the fuel system... :doh: From 18 at idle I got to 16 PSI at 80 MPH at WOT... 2-3 PSI drop is fine but a 9 PSI drop is a serious problem... * Stock fuel system (which I doubt since your at 18 PSI)* Suction restriction* Still got the stock line between the VP44 and stock filter* Suction air leak* Defective lift pump

Share this post


Link to post
Share on other sites

Whats the best course of action?

FASS Drop-in + Relocation Kit

Fass Single Filter?

Truck has 275K, no mods; getting ready to drop in 50HP Injectors.

--- Update to the previous post...

Got code P0606 this morning, had to drive the 92 to work.

--- Update to the previous post...

So the truck started and threw the 606 Code

Used the Code Reader to clear the code. Code has not reappeared. VERY leery about driving the truck.

Looking at $400 to rebuild the ECM.

New HArnesses are NOT available from the "friendly" dealership anymore.

I want to fis it correctly, but I dont want to throw big $$$ at the wrong parts :cookoo:

Share this post


Link to post
Share on other sites

FASS, Raptor or AirDog is fine... But no FASS DDRP... The DDRP doesn't have the volume nor does it correct the plumbing problems. As for the P0606 is a ECM failure code... Something happened there. Hmmm... But since the code hasn't returned I won't worry to much... But now if it comes back then you'll have to deal with the ECM.

Share this post


Link to post
Share on other sites
:iagree: when it goes the only leg you will have to stand on will be the wrecker.

Share this post


Link to post
Share on other sites

I found a problem in the harness today :

A green/white wire and a red/white wire with abraded insulation/bare wire exposed. I used liquid tape as a temporary repair

Posted Image

--- Update to the previous post...

The two wires are located to the left of the white harness retainer

Posted Image

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...