Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
jlwelding

Black Smoke

Recommended Posts

I am into my second week with my 05 with 38k miles and it seems it smokes a little heavy. When I get into it it smokes like my second gen with 50hp inj. and the Edge EZ hooked up. Are these trucks going to smoke like that? It only has 38k on the clock.

Share this post


Link to post
Share on other sites

If it is stock, no, it should not smoke like that. Check for any boost leaks you can find. There is also a possibility that there is an injector problem too......

Share this post


Link to post
Share on other sites

I have checked boost boots and they look good. Where else would boost problem be? I would hope like h--- the injectors are ok only 38k.Can a diagnostic scanner obdII determine if it's injectors?

Share this post


Link to post
Share on other sites

I have checked boost boots and they look good. Where else would boost problem be? I would hope like h--- the injectors are ok only 38k. Can a diagnostic scanner obdII determine if it's injectors?

No... OBDII can't see that... Just like the 2nd Gen 24V... Only different is the CR is electrically fired not pressure. Like said before lack of boost pressure... Might be time to throw some gauges in...

Share this post


Link to post
Share on other sites

I just came back from test drive and must say that think got HP, you can here it spool up and set you back in the seat. If it had boost leak it would"nt run that good would it?

Share this post


Link to post
Share on other sites

Remember on thing...

"Boost doesn't make power fuel does"

So now saying that you can still have good power and lower boost pressure and still make good power but now your EGT's rise quickly. This is the most common problem with guys getting large injectors... Lots of smoke but not enough boost to clear the smoke and control the EGT's.

Even when I blew a single 6mm bolt out of the manifold I was down to a max boost pressure of 8 PSI still had all the power I want but smoke and EGT's... :stuned: Holy chit dude! The whole thing cause by 1 single 6mm bolt popping out of manifold.

Share this post


Link to post
Share on other sites

Does the smoke clear up as the boost builds?Any Gauges?Are you sure there are no mods on the truck?Do you have the plastic tanked intercooler? Common issue in early 05's. Most HPCR's don't smoke at all, but I have also seen several 05's that smoke pretty good stock and they are bone stock trucks without injector issues. HPCR's are very sensitive to timing as far as low boost smoke goes, so your truck may simply be one with a more advanced tone ring from the factory.. or the PO put a timing advance mod on the truck. HPCR injectors don't normally fail and roll coal, they usually shake and rattle. There are some more OBDII tests that can be done on HPCR injectors, but still not a perfect scenario. What type of fuel filtration is on it?Also, with a Cat on the soot can load up in the cat and when boost is applied it will blow/cook it out and smoke for a while.. SO if you drive very easy for a long time then get on it, well you get the idea...

Share this post


Link to post
Share on other sites

It's got the alumin (how ever you spell it) cooler and the guy I bought it from didnt seem to know anything about doing mods or just acted that way. Yes it clears up after about 3-5 seconds and it's got some brown mixed in with the black. And yes I do baby it around, in fact last night was the first time I got in it that heavy and even still had a little pedal left.I had 75 hp inj on my 01 with ez and it didnt smoke like this 05 does.

Share this post


Link to post
Share on other sites

It's got the alumin (how ever you spell it) cooler and the guy I bought it from didnt seem to know anything about doing mods or just acted that way. Yes it clears up after about 3-5 seconds and it's got some brown mixed in with the black. And yes I do baby it around, in fact last night was the first time I got in it that heavy and even still had a little pedal left. I had 75 hp inj on my 01 with ez and it didnt smoke like this 05 does.

Sounds like it could just be a bunch of accumulate soot in the exhaust system... Get on it hard a few times and see if the density reduces. Best thing would be to tow something and get the EGT's up for a while to clean out the cat.

Share this post


Link to post
Share on other sites

Did you buy this as a "used" truck??? If so, and you cannot find anything "obvious" wrong...........is it possible that there's a programmer installed in the ECM???

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...