Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

HEY GUYS I dont spend much time over here on the 12valve side, I have a Buddy that just bought a 96 12 valve 2500 2WD W/Auto trans and his O/D is not working. The O/D Off Light in the dash is working indicating the switch is doing its job..shifts great 1-3 but no O.D.:duh: Anyone now what would cause this :shrug:Richie

Share this post


Link to post
Share on other sites

Check the relays and fuses, try swapping the tranny relay with another.

Try to take out the T.P.Sensor,and clean it.I did It on my Cunnings,and the Overdrive works perfekt.:thumb1:

Share this post


Link to post
Share on other sites

Also check the brakelight switch. Also scan the computer for any trans. codes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...