Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
blk90s13

Cluster problem ?

Recommended Posts

Here we go again :spend: :spend: I did this http://dodgeram.org/tech/repair/elect/inst_panel_check.htm and nothing came up the oil pressure and check gauge lights keeps coming on and off all day and the fuel gauge keeps going up and down as well as the fuel light And its related to how smooth I drive ? it seems like its somewhat related to hitting potholes etc on the road unless I am just going nuts :lol:

Share this post


Link to post
Share on other sites

i had a similar problem awhile back. the temp gauge was going crazy and the check gauges light came on. i ran a diagnostic check on the cluster and it said it was bad and i replaced it. i did not help. i did have alot more problems than you do though and could not drive the truck. it turned out the ecm took a dump. you might try removing the cluster and check and clean your connections. if i read your sig correctly you might be able to swap the clusters and see what happens. not sure about the manual and auto though. i have a spare cluster from an 02 manual if your are any where near me to try it.

Share this post


Link to post
Share on other sites

If you have the factory manual go to pages 8j 18-20. All the info from the sensor go into the PCM and are then sent to the instrument cluster. Either the 50 pin connector at the PCM is loose/dirty, or the PCM is bad.The connector at the cluster is just a bridge for info FROM the PCM.:2cents:

Share this post


Link to post
Share on other sites

cant find my wiring diagrams, but the 50 pin connector is on the ecm and not the pcm. i know the ecm reads the sensors and it might very well have to go thru the pcm to the cluster. that part i dont know. when i replace my ecm my problems went away. Have you checked for any trouble codes? those would help alot.

Share this post


Link to post
Share on other sites

Dripley, you'r right.

[*] :doh:

The PCM has 3-32 pin connectors. One of the PCM out put is "CCD bus (+/-) circuits for: speedometer, voltmeter, fuel gauge,oil pressure gauge/lamp, engine temp. gauge,and speed control warn. lamp." page 8E-19

Share this post


Link to post
Share on other sites

the fsm is in the download section. have you checke for trouble codes?there are wiring diagrams there also.

Share this post


Link to post
Share on other sites

As for the instrument panel it get its information over the CCD network. It relies on the other computers (ECM and PCM) to send the data across the CCD network to the intrument panel. So what happen is the ECM calls out on the CCD network and request to send oil gauge info to the instrument panel. The instrument panel has to Acknowledge it and receive the data. More on the CCD network... http://mopar.mopar1973man.com/cummins/general/ccd/ccd.htm @ MarbleCrusher... Dodge FSM's are here on the forum already... http://forum.mopar1973man.com/downloads.php?do=cat&id=19 Or go to... www.pdftown.com

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...