Jump to content

Archived

This topic is now archived and is closed to further replies.

Wild and Free

02 cruise control will not turn on

Recommended Posts

Ok I tried to down load the 02 schemeatic but I am missing a program to open RAR files with. what is rar and what program do I need to open it?As for the cruise It will not turn on, the light in the dash will not come on. I am not sure if the cruise light is supposed to self check but it doesn't illuminate at first key on like all the other cluster lights do. I put a new clock spring in today thinking that was the problem as my horn quit working as well but after taking the column trim off I found 3 broken wires which I fixed and replaced the clock spring anyhow. an now the cruise light still doen't turn on but the horn works again, I looked for a fuse for it in both fuse clusters and found none labeled for cruise so now I need to do some digging into a schematic or the service manual for troubleshooting ideas.Anyone have any ideas?:shrug:I hasn't worked for so long I don't even remember where the cruise indicator light is in the cluster anymore.:doh:

Share this post


Link to post
Share on other sites

Can someone post up the cruise control circuit for me please. I can't seem to figure out how to get a free program to open these files and now I got my puter wanting to open it with adobe or acrobat and I don't know how to undo that.:banghead:

Reminds me of when I spent about 3 days trying to update my smarty and it went through and I never did know how it happened.:doh:

I just want to fix my cruise, I don't have patience for things like this.:ahhh:

--- Update to the previous post...

Ok I found some info on another site that says the cruise indicater is in the odometer window and should come on with initial key on lamp test regaurdless. Mine does not come on at all. It went on to say that it could be several things from here. cluster, pcm, wiring.:banghead:

I am thinking this one will be worth a few bucks for the dealer to hook up the DRBIII to more quickly isolate the problem area.:2cents:

Share this post


Link to post
Share on other sites

Can someone post up the cruise control circuit for me please. I can't seem to figure out how to get a free program to open these files and now I got my puter wanting to open it with adobe or acrobat and I don't know how to undo that.:banghead:

Reminds me of when I spent about 3 days trying to update my smarty and it went through and I never did know how it happened.:doh:

I just want to fix my cruise, I don't have patience for things like this.:ahhh:

--- Update to the previous post...

Ok I found some info on another site that says the cruise indicater is in the odometer window and should come on with initial key on lamp test regaurdless. Mine does not come on at all. It went on to say that it could be several things from here. cluster, pcm, wiring.:banghead:

I am thinking this one will be worth a few bucks for the dealer to hook up the DRBIII to more quickly isolate the problem area.:2cents:

Its in the console under the odometer - and yes I think it does come on with key on - if you need a video to be sure happy to take on and upload it for you.

No idea on schematics for wiring.

RAR files "should" open with winzip which most windows build shave these days. Been a while since I dealt with one - its just an archive you extract like a ZIP file and then get the archived file out (could be anything).

Share this post


Link to post
Share on other sites

Can someone post up the cruise control circuit for me please. I can't seem to figure out how to get a free program to open these files and now I got my puter wanting to open it with adobe or acrobat and I don't know how to undo that.:banghead:

Reminds me of when I spent about 3 days trying to update my smarty and it went through and I never did know how it happened.:doh:

I just want to fix my cruise, I don't have patience for things like this.:ahhh:

--- Update to the previous post...

Ok I found some info on another site that says the cruise indicater is in the odometer window and should come on with initial key on lamp test regaurdless. Mine does not come on at all. It went on to say that it could be several things from here. cluster, pcm, wiring.:banghead:

I am thinking this one will be worth a few bucks for the dealer to hook up the DRBIII to more quickly isolate the problem area.:2cents:

my cruise light does come on at intitila key on just like you say. i had a problem with mine a while back on the rebuilt ecm. the cruise light satyed on all the time but did not function. never got to find out what was wrong because the ecm crapped out and i had to get a new one. the cruise works fine now. the cruise work differantly from an auto to a manual. my manual i believe is controled thru the ecm and is all elctronic i believe. an auto uses a selonoid controle thru what i dont know but it is differant.

Share this post


Link to post
Share on other sites

Thanks to ISX and Mike for both sending me files.I got it figured out. Starting at the switch I didn't have power and since I had broken wires were the wheel tilts I went back down the column and sure enough I found another wire that hadn't pulled apart yet but was broken inside the insulation. So after several crimps I am totally back in business again.:hyper:

Share this post


Link to post
Share on other sites

I miss it but can't hardly use it, with my mods it surges too bad driving empty with no load. If I have a trailer on back it works good.Thinking I wasted 40 bucks on a clockspring though after finding the broken wires but I wasn't putting it back together without the new one installed as I hate redoing things.

Share this post


Link to post
Share on other sites

surging under cruise would not make for a pleasent drive i dont think. the clock, worth every penny since you dont have to take it apart when or if it breaks. i replaced mine a while trying to fix a nother problem. the thing that galled me the worst when it was not working was the light staying on, like it was laughing at me.:tongue:

Share this post


Link to post
Share on other sites

Well at least it fixed Right? :shrug:

Yep works again. I really should try the needle valve trick like some use on fuel pressure gauges to limit the vacuum going to the servo to slow down the reaction and thus eliminating or reducing the surge. I have the wd40 straw reducer installed with absolutely no affect.

Share this post


Link to post
Share on other sites

Yep works again. I really should try the needle valve trick like some use on fuel pressure gauges to limit the vacuum going to the servo to slow down the reaction and thus eliminating or reducing the surge. I have the wd40 straw reducer installed with absolutely no affect.

If it was me I would tighten the packing nut on the valve a bit more so the valve handle is stiff so you can get a good setting so then later it doesn't rattle loose on you too.. :thumbup2:

Share this post


Link to post
Share on other sites



×