Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
blk90s13

Damper pulley gone bad ?

Recommended Posts

Changed the belt out about a year ago because it was older and that one went bad two days ago chewed up on the inside even the two day old belt is already starting to rip a little on the inside edge as well :mad:

so I decided to look at all pulleys while moving and the damper pulley seems to have too much play

can it be bad ? is this a common problem or anyone heard of such a thing before ?

the part is a dealer only part so far and its $420 :doh:

Anywhere else you know of sell them if I do need a new one ?

--- Update to the previous post...

This is on the 24V

Share this post


Link to post
Share on other sites

Thanks I will take a look in the day light and see what I figure out

--- Update to the previous post...

I have a fluidampr the reason i needed one was on shut down it would squeak. Mine was 412.00.

http://www.klmperformance.com/fluidampr/harmonic-fluid-damper-fluidampr.htm

I didnt get mine here ^ just wanted to show you. So to answer your question yes they go bad. Mine did not shread my belt. Make sure everything else is ok.

Oh a squeak is something mine does at shut down as well

Share this post


Link to post
Share on other sites

My 01 squeeks everytime also, dont think it's a big deal because it will squeek when belt is old and new. And maybe my tensioner is a little week but it has not efected anything in 5 years Ive had it. My 05 does not squeek :shrug:

Share this post


Link to post
Share on other sites

My truck has squeeked on shut down since it was new. Still does. I wonder about the idler pully, I had one fail on a Ford Ranger (2.2 natural diesel (no turbo). Not sure if the pivot wore first or the ball bearings but both were junk when it came out.

Share this post


Link to post
Share on other sites

I tried to figure out if it was bad today but no luck other than seeing it shake while running so I ended up taking it to my friend's shop who looked at it and said it does need replacementNow where can I get one for a deal ? I am so broke its not even funny :banghead:

Share this post


Link to post
Share on other sites

try rockauto.com.

Thanks for the link all the places I looked at had them for $400 + and Rockauto got one there for $117 :stuned: can that be true ?

Share this post


Link to post
Share on other sites

I go through these things every few years. You can see the rubber coming out when they get old.

Share this post


Link to post
Share on other sites

i was wondering what you think of the fluidamper. i have been thinking about getting one for my truck.

Share this post


Link to post
Share on other sites

i was wondering what you think of the fluidamper. i have been thinking about getting one for my truck.

I have one, years of use with 3000+ rpm no trouble. Solved my squeak problem at shut down.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...