Jump to content

Archived

This topic is now archived and is closed to further replies.

Heavyd1980

No defrost

Recommended Posts

Ok guys my wife tells me that her car 2003 Nissan Altima 2.5S wont defrost or heat up unless the car is moving down the street. If she stops at a stop sign or in traffic the car will stop blowing hot air?!?:banghead: Anyone have any great ideas on where to start with this problem?:shrug: Thank you for any and all help!

Share this post


Link to post
Share on other sites

I googled it & came up with air blocking the heater core... at RPM the water gets forced by it. There is TSB on bleeding the air: http://www.justanswer.com/car/12e0j-i-m-having-problem-2003-nissan-altima-heat.html It might well be the radiator cap return gasket is shot so it is drawing air allowing this to happen. I went nuts with dear daughter's Pontiac Sunbird that had a system that had to be purged.

Share this post


Link to post
Share on other sites

sorry about the late response I didnt get an email notification! Thank you for the time and info Flagman!!! I would love to report back that I got it fixed but my wife had a better idea and we traded it in two days ago. So problem fixed i guess!:ahhh:

Share this post


Link to post
Share on other sites

sorry about the late response I didnt get an email notification! Thank you for the time and info Flagman!!! I would love to report back that I got it fixed but my wife had a better idea and we traded it in two days ago. So problem fixed i guess!:ahhh:

Ok so you trade the Nissan in so what did you get to replace it? Come on we need to see pictures... :cool:

Share this post


Link to post
Share on other sites

Not a problem , I am always up to help in any way I can . I am not up on my CTD as well as most , but have the gasers down pretty good .

Share this post


Link to post
Share on other sites



×