Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
cumminapart

electrical issues again.. ugh

Recommended Posts

Okay awhile back maybe 20,000 miles tops I replaced my alternator and all was good.....Well except 3 random times when the truck just completely shut off beginning with the radio and everything turning off followed by the engine dieing a second later. Everytime it cranked over and started right back up no problems.Now today i lost charge... gauge went all the way down to nothing and the check gauges light came on.After driving home I shut it off and turned it back on... the voltage read around the 12v mark as I believe it should if it is just pulling off the batteries but not charging.I took the alternator off and had it tested... they claimed it was bad and though skeptical I got a new one which didnt change anythingI cleaned all the battery terminals and had the batteries tested.. both checked out goodNow I am at a losspossibly time for a new PCM? I realize that it could be just about anything when it comes to electrical though.

Share this post


Link to post
Share on other sites

Check the blue wire to the alternator it should be +12V and the green wire should be a variable ground. Now if you unhook the green wire and add a ground from the alternator to ground itself the alternator should be in full runaway overcharging. Did you check the alternator fuse?

Share this post


Link to post
Share on other sites

Check the blue wire to the alternator it should be +12V and the green wire should be a variable ground. Now if you unhook the green wire and add a ground from the alternator to ground itself the alternator should be in full runaway overcharging.

Did you check the alternator fuse?

fuse was ok but i'll check the green wire tomorrow and report back

now youre saying unhook the green but keep the blue hooked up and then instead of that green (ground) going to the pcm where the voltage is regulated by varying the ground it will go straight to full ground causing the unregulated voltage to runaway

if it does this then the old mopar style regulator will fix my issue correct?

--- Update to the previous post...

I have 12v off the blue wire and no overcharge when i ground out the green wire... nothing happens when i do this

I had the plug connected normally and opened up my splice from before on the green wire and ran straight from the alternator to the ground on the battery and several other spots while someone watched for it to start charging but nothing happened

im going to take off this new alternator and go see if i can get them to give me my old one back and money back and have my old one tested at a different location

--- Update to the previous post...

well i just got back from carquest but they wont have my original back til tomorrow

however he put the one they gave me onto the test bench and it didnt work

now its got me wondering could my truck be causing them to burn out instantly? i dont think that would really happen

or are they lying and didnt actually test the new one before giving it to me or maybe their test bench is malfunctioning it did look like it was quite old and the guy seemed sketchy on using it

Share this post


Link to post
Share on other sites

Ugh.. It ended up being the fuse I didn't look close enough the first 4 times.However the one car quest gave me was bad I made him show me when I brought it back and it didnt work so he got me my old one back which was also bad after making the cruise to autozoneGlad I did it that way though because autozone replaced it free of charge Sent from mobile

Share this post


Link to post
Share on other sites

Yea from now on I'll do the extra miles to autozone rather than car quest though .... Cheaper and they looked up my alternator and it was still in warranty so swapped me another one no questions asked free of chargeSent from mobile

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...