Jump to content

Code P0500


Recommended Posts

Just did the key trick and found a P0500. I find on the Forum that it has to do with the Speed Sensor Control. Planning on leaving on a 2.5 month trip next Monday and was wondering what action to take, if any, before I leave. Also, being a non motor head old fart, I don't know how to clear the code. If it just affects the speed, I have a GPS and a Scan Gauge on board. Any advice will be greatly appreciated.

Link to comment
Share on other sites

Mohok,The P0500 can be set from something as simple as spinning the tires lately. The computer has sensed a funny input from the rear wheel speed sensor. It is located on top of the differential.If your speedometer is still working and you do not have an ABS light on, the code may have just been from a strange spinning incident. To clear the codes you have to use a code reader or scanner. Most of the parts stores like Advanced, Autozone and O'reilley will read and clear them for you.Not hard to replace. Both the cruise control and the Torque converter clutch (TCC) (lock-up) use information from this sensor to do their respective jobs. I hope your problem will clear with a code reader. If not you should replace it, or have it replaced pretty quickly. A long trip without lockup in 4th gear can lead to higher than normal transmission fluid temperatures.HTH Hag

  • Like 1
Link to comment
Share on other sites

Just did the key trick and found a P0500. I find on the Forum that it has to do with the Speed Sensor Control. Planning on leaving on a 2.5 month trip next Monday and was wondering what action to take, if any, before I leave. Also, being a non motor head old fart, I don't know how to clear the code. If it just affects the speed, I have a GPS and a Scan Gauge on board. Any advice will be greatly appreciated.

Just went to Auto Zone for a scan and no codes detected. As a double check I stopped by a friends place and had it read again, no codes. On the way home I remembered that my Scan Gauge would detect codes also. Duh!!! Guess I over reacted. Hopefully this is a non issue at this time.
Link to comment
Share on other sites

×
×
  • Create New...