Jump to content

POP testing Injectors?


Recommended Posts

As long as you keep dont mix and match parts they should be the same as before you took them apart.

ok thanks!

- - - Updated - - -

From what I was told from the shop in Lewiston, ID no pop testing is required if you do not mix an match parts between injectors.

Ok thanks Mike so you have cleaned them as explained and put them back into your truck with no adverse effects without pop testing after cleaning... ? sounds good to me...

Link to comment
Share on other sites

  • Owner

I got a set of RV275 injector right now that are way past replacement (400K+ miles). Like I'm getting a random misfire again as the weather cools all I got to do is pull them clean them and re-install them again I know they would work good again... But I'm not sure I want to keep have to clean injectors because there plum wore out.

Link to comment
Share on other sites

I have taken a few sets apart and cleaned with no change in the way they previously ran.

Ok thanks Mike! much appreciated !:wink:

- - - Updated - - -

I have taken a few sets apart and cleaned with no change in the way they previously ran.

Thanks Ryan,

BTW: I see you have bigger than stock injectors... did you see/hear experience any intermittant IDLE at start changes "loping" or intermittant longer cranking to start...? I went from stock to 85hp injectors and this is what I am experiencing... I am going to reinstall my stock ones and see if this behavior goes away...

- - - Updated - - -

I have taken a few sets apart and cleaned with no change in the way they previously ran.

Mike, I took them apart and paid attention to when the broke free... (using a snap-on digital torq wrench) they all broke loose between 38-40ft lbs.

What would you re torq at?:think: thx

Link to comment
Share on other sites

Nope, these injectors idle better than any other set I have ever run in the truck. Never a lope and quick as I touch the key its rattling away. I torque mine to 32ft pounds with snap-on digital tq wrench.

Roger that on the torq... WOW... whats the low down on your VP44? is it stock, original, re-man U'd, upgraded... if original stock how many miles are on your truck?
Link to comment
Share on other sites

Well I did the last resort to see if my IDLE issues would go away... I put my Original stock injectors back in and NO more loping, rough Idle, hard starts or stalling...! :party018: The only thing I will missing is the "on demand smoke" that the 85hp injectors provided... but i much rather NOT have the issue that they brought with them... (MY VP44 for whatever reason just flat out does not like them) I took apart and cleaned the stock injectors before putting them back in. Starts up instantly... Idle a solid 800rpm and when I dial up the Edge I can get some BLACK on launch.... the trucks happy and so am I :thumbsup: thanks for all you guys HELP... I've learned alot :party018:

Link to comment
Share on other sites

Did you buy these new from II or secondhand? I had a set of 75hp nozzles in my truck for about a week and took them out for bigger, they ran and idled great in my truck. Fast forword 4 years and put them in my buddies truck, they lope at idle but do run good. I dont know why they would run different on different trucks but sometimes they do.

Link to comment
Share on other sites

×
×
  • Create New...