Jump to content

Recommended Posts

on my 99 dodge p pumped truck i am having a major issue. 2 days ago i go to start the truck up and all the guages stopped working except the fuel gauge and speedo. Oil, tach, volt, temp all are on zero. ac does not work either. after driving the truck for say 5 minutes, all the gauges kick back on and the ac starts to work. i have checked all grounds, power, and fuses and everything seems inline. this mornign i drove it for 10 minutes and the gauges did NOT come back on. also cannot check for codes as the scanner will not connect to the truck now. weird part is it does not say NO BUS in the odometer. sometimes the scanner will work and most times it will not. only codes i have been able to pull other than the fuel injection pump stuff since its no longer there is a grid heater relay. not sure where to check or what to check. any help is GREATLY appreciated. thanks.

Link to comment
Share on other sites

  • Administrator

CCD Network failure. Sounds like a loose wire. http://articles.mopar1973man.com/general-cummins/34-engine-system/81-ccd-data-bus When the CCD network dies (NO BUS) the computers can't share information. So the PCM is asking the ECM is the engine OK? ECM replies yes coolant is good, not WOT, and no limp mode you can fire up the A/C. So in this one example I showed how some basic communications occur. Read the article and it will explain some basics.

Link to comment
Share on other sites

CCD Network failure. Sounds like a loose wire.

http://articles.mopar1973man.com/general-cummins/34-engine-system/81-ccd-data-bus

When the CCD network dies (NO BUS) the computers can't share information. So the PCM is asking the ECM is the engine OK? ECM replies yes coolant is good, not WOT, and no limp mode you can fire up the A/C. So in this one example I showed how some basic communications occur. Read the article and it will explain some basics.

thanks micheal so how do i diagnose and or troubleshoot the ccd system?

- - - Updated - - -

also what has me stumped is looking at your picture of the ccd communication picture, the ccd does not have any communications with my ac or my atlernator. yet when my gauges are not working, neither is my ac or alt. just not sure how to troubleshoot the ccd system

Link to comment
Share on other sites

Well believe it or not I figured it out. My egt gauge was shorted out and it was tied into my power wire from my cluster harness. Removed the Guage and all is good now. Had no clue the cluster had that much to do with the bus system Sent from my SCH-I605 using Tapatalk 4 BetaSent from my SCH-I605 using Tapatalk 4 Beta

Link to comment
Share on other sites

how can i test for shorts between bus + and shorts between bus -? also can i start unplugging things and when i get communication back via obd2 port does that mean the last thing i unplugged to give me comm back is the culprit of causing the dash problem? dash cluster test checked out as pass. over head comp checked out as pass. only thing funny is i DO NOT get the no buss message on trip computer. just trying to figure out how i can isolate and check for the problem. gauges stopped working again this morning.

Link to comment
Share on other sites

Actually buddy had about 7 used ecms setting in the shelf. Diesel shop of course. Let me use them and I just decided to swap the used ones in until my Guages started to work again. Just so happens the first ecm u picked out of the bunch was for a 97 truck. Gauges lit right up. Only thing that don't work is cruise being this ecm is wrong for that. I will eventually get mine replaced with a new one so I can have cruise back but for now all my Guages work and ac blows cold. That's really all a ecm is good for now being I am p pumped Sent from my SCH-I605 using Tapatalk 4 Beta

  • Like 2
Link to comment
Share on other sites

That won't work on mine. I need a factory ecm for my cruise to work again. When the Guages worked with my old ecm so did my cruise. With the 97 ecm the cruise does not work. My stock apps is hooked up and working fine. I also have a standalone pcs tranny controller and shift points are based on apps. 97 ecm I have in the truck now was probably out of a truck that did not have factory cruise. Sent from my SCH-I605 using Tapatalk 4 Beta

Link to comment
Share on other sites

×
×
  • Create New...