Jump to content

A/C Hot then Cold and Fan clutch issues


Recommended Posts

Here's some background:

aprox 3 months ago before the hot season in Phoenix, AZ i wanted to get my ac working again so I replaced the liquid line and suction lines along with the orifice tube due to the leaky ball type valves in the lines. And i had noticed at the time my fan clutch was free ballin... so while I was at it i replaced the fan clutch with a 89 dollar Hayden fan clutch from Rock auto. Three months later into the hottest part of the year, that fan clutch engages at cold engine start up drive a couple miles and disengages. At the same time I have my ac running and it get's cold about 45-48 deg while moving. Come to a stop light and the darn ac climbs to almost 80. Mind you sitting at a stop light for 5 min in 110 deg ambient temp you would think the fan clutch would engage but it does not. Seems to only engage when im hauling my trailer. Needless to say I went and bought another new fan clutch from NAPA. I have had two of these things due to the fact they will never disengage. Im at the point of telling napa to shove these things cause im tired of changing fan clutches in the hopes that it will work. For now im going to put the Rock auto fan clutch back on because it would at least cycle and get my money back from NAPA. Forgot to mention that i did take the time to clean my radiator fins, inter cooler, and condenser coils to make sure air flow wasn't the issue. Im at a loss here Posted Image why i cant get this fan clutch to cycle right. Im almost ready to put a pusher fan on the condenser to see where that gets me since they are roughly 40-50 bucks.

As for the compressor cycling.... cycles like it should at idle, and anything above 1100 rpm and it cycles real fast making my air temp rise by 5 deg or so. Course you can hear the fan clutch roaring away since I have the napa clutch on that has never disengaged and i installed it two days ago. With the Rock Auto Clutch compressor will totally disengage due to high head pressure.

So lol any idea's out there? Posted Image

Link to comment
Share on other sites

my '99 was doing that until last thursday.my clutch has never locked up the entire time i've owned it. i took it off this winter(for better mpgs) and only put it on cause when idling at a long traffic light, the a/c would blow warm air(and on 100*f days would get up to 215*f at long lights during rush hour, my soon to be ex-wife never looks at gauges) .i also bought 1 of the DIY freon chargers from wal-mart and noticed that it was a little low. before it would cycle while idling, but afterwards, when on MAX, it never cuts off.it blows a little colder also. when i was charging it, if i held the RPMs @ 1200 the line barely had 25psi. after a 14oz can of freon, it stays around 35 @ the same RPM

  • Like 1
Link to comment
Share on other sites

×
×
  • Create New...