Jump to content
Sign in to follow this  
Aggie08

Radio and Programmer stopped working at same time

Recommended Posts

Buddy has an 2000 2500 4X4, Edge Juice with Attitude, FASS lift pump, new VP some time agoRadio and Programmer do not turn on when turning on the truck. Happened after filling up at the station.:think:Has checked fuses under hood and door panel and wires look good. All other electrical seem to work right now(windows, locks, cig lighter, ect) and truck runsAny ideas?

Share this post


Link to post
Share on other sites

He confirmed they were good, even swapped them out anyway and got nothingMoparMan- did not see your post till now...seems that was the prob right now

Share this post


Link to post
Share on other sites

Ok, Im the owner of the truck mentioned by the OP. I pulled the I.O.D. fuse. It was burnt. Swapped with another, radio turned back on, Then the cts module for the edge started smoking in the cab. After pulling the connections, one hole was melted a it. I cleaned it out, now no more smoke but still not turning on. Guessing i blew the cts module now?

Share this post


Link to post
Share on other sites

yea, Its powered by the obd port. Sorry earlier i was only looking at fuse panels, and was thinking you meant what fuse is used for the signal wire (the fuse that the wire is attached to)

Share this post


Link to post
Share on other sites

Roger that. Preciate the help fellas.

- - - Updated - - -

Update: Called Edge this morning, after telling them the story on how it happened, they are taking the CTS module and the odb port wire back.

They are going to fix whatever problem it is and send it back. They acted as though they had never had that particular problem. They also added

that this will be the only time they do this for no charge to me. If it happens again they are sure that it has to be a problem in the truck wiring. So

the question now is, where should i start on tracing out a potential problem before the programmer returns? No other electronics have ever been

messed with on the truck, except for cutting out the door dinger.

Share this post


Link to post
Share on other sites

I would venture a guess that your edge cts shorted out, took the fuse/radio out then when you changed the fuse the short "smoked" the cts. Edge should warranty the replacement just like a new one unless there warranty specifically states one time replacements. Just my 2 cents.

Share this post


Link to post
Share on other sites

I am surprised they offered to fix it for free this time. My comp had internal issues at one point and I sent it in for repair. They even admitted to me that it had failed but they charged me the $200 service fee anyway. I was just happy to have it back so I didnt question it. I am very happy with edge products but I hope I never have to send one in again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×