Jump to content
  • Welcome To Mopar1973Man.Com

    We can see you are lurking about reading the forums and article databases. We happen to be one of the most friendliest Cummins support website on the planet. Come on and register and grab a inexpensive subscription plan. With that you can unlock even more for you. Technical support either by public forum, private support ticket, and even unlock phone support by Mopar1973Man. Mopar1973Man.Com will remain FREE to read forever!

Recommended Posts

My son and I spent about 3.5 hours out in the garage today putting on some new cables from Geno's Garage (supplied by CustomBatteryCables.com).  I know, I probably could of got them cheaper if I made them myself but a late night of shopping for one of the one touch oil drains and somehow those cables made it into my cart too :whistle2:

 

They are a really nice set of cables with all the lugs already preinstalled.  They even included rubber covers to go over the terminals but with all the additional wires I didn't put these on all of the cables.  They even have some grease and anti-corrosion pads in the box.  The cables are thicck (with 2 c's) and don't bend too well.  It took some strength and some creative cursing to get the cables bent to where they they would connect to the battery terminals and stay connected.  They were also a little long, especially the positive to starter (which was really long).  

 

We finally got them all ran and the terminals put on and all my extra cables (FASS, Quad, Headlights) connected.  I connected the drivers side + and then the drivers side -... SMOKE rolling out from under the cowl.  :ahhh:  When I removed all my cables I taped all the positives and all the negatives together so I wouldn't put the wrong wire on the wrong post.  Well, in theory that should of worked but somehow I had my negative for my FASS taped in with my positives... :doh:

 

After switching that FUBAR around and reconnecting everything I hopped in the cab and crossed my fingers.  She fired right up.  Fuel pressure gauge is still reading 15psi. WHEW!

 

 

MVIMG_20200318_194355.jpg

Looks like I'm going to have to rub grease and oil over the rest of my bumper so the finger and hand prints won't show.

 

IMG_20200318_194346.jpg

The passenger side negative gave me the most problems :mad:

 

IMG_20200318_194336.jpg

I think I might move some of these power cables down to the lug in the PDC to clean up the battery some...

 

Edited by hdpwipmonkey
captions for the pictures
  • Like 1
Link to post
Share on other sites
×
×
  • Create New...