• Announcements

    • Mopar1973Man

      Quadzilla Tunes   06/12/2017

      QUADZILLA TUNE REPOSITORY - There is now a Quadzilla tune download area. When you submit a tune file to the download area it will automatically create a forum topic that allows discussion of your tune. So export your tune and upload it to the site. Then we all can help out in building better tunes. Check it out gang...
    • Mopar1973Man

      911 Support Group   06/22/2017

      Hey Gang, I've got the 911 support group database back up and running once again. It's listed in the 911 support category. It will allow members to list their contact information and location so other have a listed of members to call upon in the time of need. So if you wish to support other member please stop by and add your listing into the database. https://mopar1973man.com/cummins/911-support.html/contacts/

Archived

This topic is now archived and is closed to further replies.

Torkyrig

cruise dash light

6 posts in this topic

replaced my heater core a while back. Now the cruise control light in the dash does not work. The cruise control functions normally, just no light. Anyone know how to address this problem?

Share this post


Link to post
Share on other sites

On my 02 I have the same no cruise indicator but I also have a non working cruise with it. I am leaning towards a bad clockspring on mine but I rarely use the cruise on it, with my mods it surges too bad with the cruise on.

Share this post


Link to post
Share on other sites

I think I just have an indicator light issue as my cruise works. Have you tried a needle valve in your cruise control vacuum line? It really helps the surge on my truck. I can use cruise with my smarty and injectors, but not if I turn the PM3 on. It's not stock power smoothe cruise, but accceptable if I'm empty.

Share this post


Link to post
Share on other sites

I think I just have an indicator light issue as my cruise works. Have you tried a needle valve in your cruise control vacuum line? It really helps the surge on my truck. I can use cruise with my smarty and injectors, but not if I turn the PM3 on. It's not stock power smoothe cruise, but accceptable if I'm empty.

if your cruise works but no indicator it is most likely either a pinched wire or burned out led. if your cruise does not work, and no indicator it is either a malfunctioning switch, clockspring, wires or worse yet a bad ECM(manual tranny)/PCM(automatic).

Share this post


Link to post
Share on other sites

I also believe it is just a light/led issue, maybe wiring. So does anybody know how to get to the instrument lights and where/how to replace them?

Share this post


Link to post
Share on other sites

Remove bezel, be careful, it is held with metal snaps.Lower your steering column, it helps, start at 1 side and worth around, be careful, it is fragile.Put it to the side, the dash is held in with phillips screws or small torx, sorry I can't remember, 6 I think.The dash is connected with some wires so go slow and tilt it forward after the screws have been removed.Remember the position of the cruise light.The bulb is very small and unscrews from the back, small flathead will fit. 1/2 twist to remove.The bulb is available from the dealer.Pricey little devil, considering the size.Should only take you an hour or so, not complicated.Good luck.

Share this post


Link to post
Share on other sites