Jump to content
Sign in to follow this  
nfewell34

Truck Missfire

Recommended Posts

Here latley When I go to start my truck in cranks then misses but then fires right up and runs fine all in one turn on the key....Say i drive home trun truck off wait 10 mins it will fire right back up....But say I wait hour or longer and come out and try and start it will miss crank miss but then fire right up...I am driving in 06 with aftermarket S&B intake...and straight pipe exhaust...just tripped 29,000 miles...Any ideas?...my guess in air in fuel lines? or injector ??? any help would be great thanks!

Share this post


Link to post
Share on other sites

Ok... With the 3rd gens... Air in the fuel (bubbles) - Might cause missing...leaky injector(s) - This will make it difficult to start sometimes...Weak lift pump pressure - Could cause a problem...The biggest problem with 3rd Gen trucks is the expensive injectors (about $2,000) and getting a good quality filter (2 micron) to protect them...

Share this post


Link to post
Share on other sites

That would be since...it really didnt start doing it tell after the dealer serviced my truck and all that good stuff...they warreny all thier work and truck is still under warrenty so thats where I am takin it to..thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×