Jump to content

2007 Chevrolet 2500 6.6 Diesel won't start HELP!!


Recommended Posts

I have a 2007 Chevrolet 2500 HD 4x4. I drove it to the store a couple days ago, it was running fine on the way there and back, but when I got home I killed it and it wouldn't start back up. I can get it started with starting fluid but it won't idle. I cant find the fuel pump on it either. The repair manual says it's a frame mount, the Chevrolet house said it was in the tank. I dropped the tank and it was not there. Can anyone give me any ideas what's going on?
Link to comment
Share on other sites

If it will start or run on a spray then it is a fuel related problem. The fuel pump should be in the tank where the module is and is part of the module. Check to make sure there is power going to the pump module first.Tom

Link to comment
Share on other sites

Oh, I thought you meant lift pump...... Sorry. They do have a CP3 pump and from what I understand they can get by without a lift pump (but I don't know that for sure). The first thing I would do is try scanning the computer to see if anything is there. Also check for any loose plugs that are related to the fuel system.

Link to comment
Share on other sites

It could be a lot of things (bad fuel/filter/leak/cps/electronic issue). Could be air in the line/bad seal/forgot to put the ring on it/bad fuel. Not sure what applies to yout situation but I would start with a new filter/seal/bleeding to elimate air....maybe it's due for a change or you just changed it/had it changed and something isn't right.I have also heard of hair line cracks in the filter housing that are hard to locate. How soon before this did you fill the tank? I don't know if you belong to any dmax forums (I did when I had a cpl dmax trucks), but you could read for hours on this issue so hopefully it's not bad fuel or the CP3 and it's an easy fix. Good luck!

Link to comment
Share on other sites

×
×
  • Create New...