Jump to content

Chris01cummins

Member
  • Content Count

    13
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Unskilled

Personal Information

  • Location
    Allentown

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Chris01cummins

    Chris01cummins

  2. I just really dont want my family to get hurt because of this. Its are only vehicle tho. When it locks, that's it you along for the right. It's like I'm on ice. The front dont do anything. If I brake normal, stops just fine.
  3. It was an old farm truck. Yea me too. That's why I thought I would ask because I cant figure it out.
  4. Ok. I took notice earlier that someone change the front and rear brake lines. The front lines are about half the original size. I know this because they left the old one running across the front cross member. The back still has the original load adjusting lever for the rear brakes.
  5. Yea, no problems with that. Also when I hit the brake pedal, it kicks back...
  6. Hey guys can someone please help me. I had to emergency stop twice now and all the truck did was lock up the rear tires and the front did nothing. Rear abs does not work but the light does not come on to tell me there's a problem. The light does work when you turn the key on, then goes out after a couple of seconds. I'm not sure if my truck is supposed to have 4 wheel abs or not but I found the abs wires cut at the hubs. Any help would be great. Thanks
  7. Oh ok thanks. Just don't know what it could be. What should I look for in the live feed?? I'll have to barrow someone's lol
  8. I have a feeling it might be something in the trans. Driving it on a good or bad day, I have to push it pretty hard sometimes up a hill (empty with just me in it). I even see a difference when I have 4 or 5 passengers in the truck. Could it be the torque converter? Most of the time I have to get a running strat. But from standing still I could light the tires up if I wanted to. Oh and the problem was there before the edge. I was hoping that the edge would help the truck but it still does the same thing.
  9. I don't have any codes. It's not temp related because it does it sometimes on the same day.. I'm trying to find a diagram for all the ground wires so i can check them. It's just really weired.
  10. I was wondering if someone can help me figure out my truck. Sometimes when I start it up and drive it, it drives like a brand new truck. Sometimes I start it up and drive it, it's a dog. I can't figure out what's causing the problem. Fuel pressure is always the same. 19psi running and 16psi driving. All other gauges are in normal range.
×
×
  • Create New...