Jump to content

Dustin24v

Expired Member
  • Content Count

    28
  • Joined

  • Last visited

Everything posted by Dustin24v

  1. Update, when viewing live data I found that my Actual throttle position is set at 12.5 which should be 0. And when it revs up, I do see it on my scanner. Does that mean the timbo is shot? It didn't last long if it is.
  2. Ah I see. I don't have the dead pedal issue either. I still have full throttle response when I push the pedal. But, even tapping the pedal a bunch doesn't drop the rpms I have to shut it off for it to stop. It's very strange... I would think a code would show but nothing... I turned offf and returned the programming to stock on my chips and still no luck. Do you think it really is electrical and not mechanical ie sticking injectors?
  3. No codes. Checked with blue driver and smarty. When I was viewing data live the throttle percentage would stay the same no spikes while driving, but of course it won't do it when I watching data live. As far as signs wire, do you mean the one to the tps?
  4. Over the last 3 weeks, I've had an issue with my truck accelerating by it self. Not WOT like other posters experience but more like going from let's say 15% throttle position to 25%. At normal cruising speeds 35 or 60 on the free way it will happen a few times then stop. Other times I'll be going through a parking lot trying to find a spot and my truck will keep its rpms at 1500-1800 and I have to hold the breaks or shut off the truck and restart. I tried a apps reset eventhough I have timbos tps. Tried leaving the batteries disconnected for 24 hours. Tried running Lucas for injectors. Tried a known working tps(another persons truck with no reported issues tps) I have a new vp44 from thoroughbred with 6k on it. Timbos with about 28k. 7 x.0010 injectors about 35k Any ideas? My next thing I'm going to check is vacuum leaks.
  5. Dustin24v

    Dustin24v

  6. I may need to readjust the bost elbow then. I cant remember but I believe I just closed the port all the way and backed it a turn and it was right at 32. Might have came loose. And with my pump, I'll try increasing the pressure before I buy a new pump.
  7. It's the 17ss from goerend. Basically stock stall speed. To everyone's conclusion I need a new turbo. Basically trying to decide whether to sell some guns or just throw it on the plastic devil. I'll be doing the ground mod today to see if it helps any. It will be good to reduce some ac noise anyway. @Mopar1973Man so I was looking at how the previous owner set up the bd noise isolate. He snipped that wire and only left about an inch from the computer. Do I need to replace with a full length wire and reattach it somewhere?
  8. Oh I see. I'll have to read more into that then. Most forums advise the super b special is great for 12v I assumed the Same for the 24v. I'm not too familiar with turbos. I do know when I was talking to Jon Dynamic. He was saying I needed a larger turbo just for the fact I had a triple disk tc.
  9. Why is that in your opinion? I read that the benefits of the 14 is less turbo bark and more durability. Do the 12 blades spool faster?
  10. I was looking at the sxe 300 64.5/73/14 and was trying to figure the difference between the two. Seems like the the super b I might be paying for the name a little. Finding a inexpensive 64mm 14 blade is troubling. I found a super b special for the 03-07 would I be able to rig it to my 98.5?
  11. Should I drop down to 1/2" lines instead? Or am I to the point I should get a 150 fass? Also back to boost and head studs. If I do get the super b special and waste gate at 37 psi should I be alright? I figure with the increased volume of air I wont need to run as much boost.
  12. I do a lot of trips to eastern Montana and a lot of the roads a 75mph so I need a bit more to end to pass. Also hauling wood through the hills is easier then when I was stock... i do wish my truck wasn't so loud though scares the deer miles away then I have to walk. So doing more testing with my original issue. I tried wot from 35 to 80 to see if it would do the same. TC locked at 70 no surging or bark and psi stayed at 32 for boost... My guess higher speeds less load during lock up. Is that correct? If so should I be flooring it to get on the freeway from now on to avoid the surging?
  13. Ah ok. I will get everything done this weekend and report the news of my issues if anything it will be good preventative maintenance to keep that expensive vp44 healthy. I just switched all my accessories to the pdc noticed my gauges aren't fluctuating anymore. I'll have to get a larger turbo then to stop the surge for sure. Hopefully I can find a BD Special for cheap or anything equal in specs. Low 500's is the most I want for hp to the wheels.
  14. Alright I'll have to give them a call. Thanks. For the w-t ground wire mod would I be getting rid of the bd noise isolate then? Also with all the accessories on the truck should I have an equal amount of leads/load to each battery or does it matter? (Accessorie Connections)
  15. Having the programmers off it should be ok to drive until I get a new turbo then correct? Or are the injectors still providing too much fuel? I was looking at the old super b specials but they are pretty pricey now. Is the special overglorified? @Mopar1973Man would ac noise also cause the engine to throttle without touching the pedal? Example. When I drive 15 min to work and coast around looking to park my truck will throttle/deadpedal until the truck is shut off. Fire it back up runs just fine then coasting around neighborhood to get home does the same thing. Does this about 1-2 times a week. Sometimes I'll go a few weeks without the problem.
  16. Sorry I meant to say that i have the Wastegate set at 32 but somehow it goes over that almost to 45psi. Was reading through your write up. It actually makes a lot of sense. Sounds like I still need a turbo though, especially with the aftermarket injectors. With terrible logic I figured if I'm not pouring out smoke that the fuel was being burned.
  17. I'll unstack it today and see if it fixes the problem. If it does I'll just keep it to pass emissions every other year. I should mention this only started happening after I put the triple disk in. If unstacking doesnt fix it any other suggestions? I've tried turning the edge off due to easy access and it still does it.
  18. Back again for my second post. So the problem is when I'm getting on the freeway if I push the throttle any more than 50% while going from 35 to get to 75. When the TC locks the truck will surge and the turbo will bark as the boost jumps from the 32psi I have the adjustable boost set at up to 45 psi. Don't know how it gets past the 32 i set it for but it does. After it locks with same throttle position after I get past 60-65 it stops and will not do it again unless I do the above scenario. I think I already know what it is, which is that I'm still running a hx35 on a built transmission and triple disk. And with all the go fast parts the turbo over spins? I should mention that I am not pouring out soot only a light haze when I do the above.(trying to keep it short sorry) I have a lot of mods... ones that are relative. New Bosch VP44 from thoroughbread about 2k on it. New timbo app 1k. Bhaf. 7x.010 SAC sticks. Edgecomp smarty stack. Goerend tc and vb. And bd stage 3 rebuild. Any thoughts of I'm correct on the stock turbo being the issue. Any ideas on how to keep the boost at 32? Bigger problems? Hunting season coming up so I'm on a tight budget... haha priorities. Thanks in advance for your replies.
  19. @Dynamic Yeah I actually did running like a champ now. 2-3 shift is a bit harsh but otherwise good. Dealing with throttle related issues now. Sorry for the late reply.
  20. Thanks for the info, I'll keep that in mind as I've probably done it a couple times just because I forget sometimes if there was a gasket or not. As far as frictions I'll take your recommendations, as the borgwarner didn't hold up to well, I suspect due to adding a triple disk without the extra line pressure from the stock vb I had. The goerend vb has the truck shifting firm now though. Hopefully the od will last this time around.
  21. @Dynamic ah I see. That makes more sense. So without being able to compress the od spring I'm just going to make the assumption those clutches might be burnt too. So parts list as follows: Friction OD BW 6 pieces Friction OD direct BW 10 pieces BW- Borg warner. Unless raybestos is just as good. What are your thoughts? STEEL OD BRAKE 6 PIECES STEEL OD DIRECT. .525 INCH 9 PIECES OVERDRIVE CLUTCH APPLY PISTON INNER AND OUTER LIP SEAL Rear bearing snap ring gasket... I may end up just using rtv for gaskets. --- I think the sun gear should be fine and same with the roller clutch assembly. Bearings seemed fine as well. Last I may need a overdrive/direct clutch press plate just in case mine warped. Hard to tell without being able to open it up... I think that is all I will need. Was looking through the atsg manual and didn't see anything else.
  22. So I pulled the od and transfer and od piston. Piston seal blew out. Also burnt up the clutches. The seal only had a 1/4 notch cut out so I assume that reduced the od clamping power due to the reduced pressure going to the od unit. @Dynamic so that definitely confirms my need for clutches as well as seals. So i will definitely stop by on Wednesday to get the parts for the od and get the truck back up and running same day.
  23. I'll pull my OD this weekend Saturday and let you know. I'm thinking I might need clutches too as my fluid was pretty dark last to changes while trying to resolve the problem.
  24. @DynamicOh alright. Would I be able to drop by your shop on Wednesday to get all clutches, seals and gaskets? Also compressing that spring is a PIA, do you have a press for the od spring that I could use for a charge?
×
×
  • Create New...