Jump to content

BrownTown65

Expired Member
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Unskilled

Personal Information

  • Location
    Milledgeville, IL

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Engine still does not start. Voltage and ground are all good to the injection pump. The neighbors snap on code reader pulled out several more codes. Picture below. We were going to jump the pump to see if we could get it going but batteries were to low. Plan on connecting charger in the morning and trying again. However we could here the pump click when we connected the wires from the pump to the battery. So not sure if that means it may still be good?
  2. It's a 2001 with 220,000 miles on it. The truck is completely stock except for a BHAF and a straight pipe. I just cycled the key to get the code, I've been waiting for my neighbor to bring down his snap on code reader. Thanks for getting back to me!
  3. Several days ago, my truck died while cruising at 60mph. There was no warning, pops, knocks, or clunks. The rpms dropped to idle then a few seconds later dropped to zero. Truck had full power until it died. Fuel pressure is good. Only throwing the p1693 code.I believe it to be a ground issue. The truck radio lost memory after sitting overnight and turned the am radio on. I'm looking for wire diagrams or someone who has maybe had a similar issue or any ideas. Anything will help!
×
×
  • Create New...