Jump to content

Anderson

Unpaid Member
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Unskilled

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. When I purchased my truck the hydro-boost had a leak, but instead of replacing the gaskets I just purchased a whole new unit, (I figured after 205,000 miles I might as well). Now 2,500 miles later of no problems or leaks, I got in my truck yesterday morning, started it, and a couple seconds of idling later there was a loud noise coming from the hydro-boost. I quickly shut off my truck, waited a few minutes and then tried to start it up again, and it started doing it again. (P.S. whenever I tried turning the steering wheel or pressing the brake the sound would get louder). However I came home f
  2. When I press the lock/unlock switch on either front door, I can hear loud motors spinning in both doors, but nothing happens (my doors don’t lock/unlock). My last 2nd gen I owned had the same problem, but I never bothered to fix it. I really want my doors to lock without having to manually lock them with my key. 1999 Dodge Ram 2500 5.9 Cummins sport.
  3. Ok, so I had the alternator load-tested while still connected to my truck, and it said it was fine. Then we used Orilleys code reader and it threw code P0602. We then cleared it and drove my truck home and it did not surge or shift weird the whole way home? But on the drive into town it was shifting weird and revving at stop signs like it has been doing??
  4. Ok so I have a 1999 Dodge Ram 2500 Cummins. It just randomly started revving and trying to turn my rear wheels and Rolling coal when I was slowing down to stop. It happened when I got down to about 10 mph, and the revving caused my truck to shake very aggressively. I also noticed it was shifting to early (my truck was shifting so early, I was already in overdrive by about 48 mph?? Any solutions/ suggestions? Thank you for any help you can provide
×
×
  • Create New...