Jump to content
Sign in to follow this  
thedsmguy

Clutch chatter or?

Recommended Posts

My truck chatters upon launch at almost any rpm idle or not. I think it has a aftermarket clutch in it, is there anything else that you guys can think of that would cause this? I've been under the truck looking for loose items but cannot seem to find anything that is loose (driveline, rearend shackles etc.)Thanks.If you really really really hit the clutch just right at a idle you can get it to drive without chattering but thats it.. Its really annoying when pulling a big trailer.

Share this post


Link to post
Share on other sites

I have not nor do I want to pull the tranny to see if anything is wrong, could this be fairly normal with a stronger aftermarket clutch?

Share this post


Link to post
Share on other sites

Well... I know mine is caused from fuel contamination... I had #6 injection line dribble down on the clutch and cause to slip now and then which in turn cause a hot spot... Which was shortly after I installed the clutch so my now is jerky or grab at launch now... I've gotten use to it... Same since I'm not going to pull the trans down to re-surface the flywheel and pressure plate to fix it... :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×