Jump to content

Archived

This topic is now archived and is closed to further replies.

jlwelding

Fixed Part of the Problem

Recommended Posts

Well here it is, after the fourth ECM on my truck we tried a test ecm from cummins, and the surge that has been there for two years is gone. HEY But the miss is still there. Ok we put truck on a delete box and what that does is it bypasses the elec. in vp and bypasses the ecm, truck ran like a dream, could not belive it if I had not heard it with my own ears. So we still think there is something going on with ecm. We know for a fact it fixed the surge. Put old ecm back on and instant surge is back. Ok one thing I have learned is there are about 12 different ecms out there for a 01 so when someone tells you there all the same - there not, I found out the hard way.

Share this post


Link to post
Share on other sites

wow! the wife and i are happy you got it figured out be for it became a target!:) is there a way to tell the difference on the ecm(ie part #, serial #, opening the case and looking)?

Share this post


Link to post
Share on other sites

As far as opening it, I have to send it back as a core or I guess pay 250.00 and keep it. HA HA Still have miss problem but it did go away with delet box. So I am still thinking it is elec. problem in ecm or wire harness. A few more thousand dollars and I should have it. lmao

Share this post


Link to post
Share on other sites

sorry man i hate electrical problems its always a minor problem that take a week of diagnosis and i cant justify the nick in the wire, buried under the dash in the massive loom of wires caused by the c/b radio the guy around the corner hooked up for you for a 6 pack. give me a rod hung out the side of the eng. anyday.

Share this post


Link to post
Share on other sites



×