Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
SoClose

New Quadzilla

Recommended Posts

So many questions...

Been reading everything I can and making calls to DAP and Marco (who has been out this week), but still coming up empty on things and looking for help.

I'll apologize up front for not knowing enough about this stuff, but I'm trying to learn.

1. Currently the only parameter that will give a reading is EGT. Not even rpm. Checked all connections and look OK, but that the brown wire to my oil filter isn't hooked up as each of the 2 taps is feeding each compound. Investigating tapping a 3rd hole for the brown wire sensor.

2. I really don't have the knowledge base to build my own tunes- for example until recently I thought advancing timing would gain power, and now I'm thinking that is completely wrong. Any suggestion where I might find a basic primer? I would like to play around and develop this but would like to start going in the proper direction.

3. Finally, been looking through tunes that are posted but haven't found any trucks that seem to have the same modifications as mine- I suppose keep looking?

Thanks for any help!

Paul     

Share this post


Link to post
Share on other sites

Nothing will work unless your gauges are working.  

 

 

Check your datalink plug again.  If that checks put get the quad looked at. 

 

As fpr tunes. What are your goals?

Share this post


Link to post
Share on other sites

Having no idea, I started with the tune from this video:

 

I can only compare with the prior Smarty/TST stack since I had that for so long. Actually runs OK with this tune and went WOT once and saw 8 more psi boost (and broke the tires out in 3rd gear). I also discovered the boost sensor is not on the intake elbow and I'll correct that.

A little more smoke when pulling away from stop, even when soft pedaling it- probably a little more smoke at all rpms but less as the rpms build. 

I would like to work on more power from around 1400 rpm to 2000 range- that's where the clutch comes out on upshifts and accelerating.

Ultimately, I would like a fun daily tune and one for the dyno- would like a documented pull over 600 rwhp. Was 598 with the Smarty/TST stack a few months ago.

I really appreciate any help! I'm studying all I can and will play around with this- would like to be nudged in the proper direction!

I'm thinking that the unit may have a flaw since everything is hooked up properly. Spoke with DAP yesterday and I believe they may be thinking the same. Will chat with Marco next week.

Also speaking with DAP about changing from the Dynomite sticks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...