Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

Just installed a new to me (Reman) VP44 after my old one went out completely. During the install I took out the factory lift pump which was mounted on the block since I already have an airdog 100 on the frame. As well as replacing push rod gasket. Blocked off mounting bracket for old lift pump with a big block chevy fuel pump block off plate (Mr. Gasket #1516) frees up some space and adds a little bling lol. So original lift pump and fuel filter are completely off truck. I go to start the truck after purge all air out of injector pump as well as injector lines. Ive done this before a few months before after new fuel filters but i definitely feel like more fuel was put out during that event than the current event I am dealing with now. Memory could also be a little blurry since the truck hasnt ran in around 2 months. SO the trucks starts smoothly but idles somewhat rough. Idle is @750 which isnt abnormal compared to idle when it was running. You can throttle all the way to the rev limiter if you wanted to but as soon as you let off throttle it stumbles then shuts off. It will stay idling for days. You can press accelerator till 1200ish and slowly slowly let down and it will stumble then go back to idle. Currently do have a fuel pressure gauge, waiting for one to ship to see if it is possibly lift pump but the pump starts as its supposed to. Any comments or tips are much obliged.   98.5 Dodge Ram 2500 5.9 Cummins. 152k miles. Auto 2wd. Air dog lift pump. 5inch turbo back. BHAF.

Link to post
Share on other sites
Posted (edited)

Update 2, so finally was able to pull the codes, a P1693 and a P0123. Fuel pressure gauge goes on the AirDog tomorrow. P0123=Throttle pedal position sensor A circuit high input. Initially after I did the vp44 install I did the reset of the tps, would a reset of the tps pull a code or is the sensor out? 

Edited by 2ndgenLorenz
Typo
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...